summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2018-10-30 19:49:29 -0700
committerMatthew Barth <msbarth@linux.ibm.com>2019-02-05 16:20:02 +0000
commit8fd879fb7bb9ed34fe69581dc714b4158046519f (patch)
treeaa33e860d7d018fd9670599039e459a4bebc6324 /Makefile.am
parenta1aef7a100a9b27d2133622a695bb8c09c2869bf (diff)
downloadphosphor-fan-presence-8fd879fb7bb9ed34fe69581dc714b4158046519f.tar.gz
phosphor-fan-presence-8fd879fb7bb9ed34fe69581dc714b4158046519f.zip
Remove timer in favor of sdeventplus/utility/timer
This removes the custom timer implementation and moves to the sdeventplus utility. Functionally this should make no change Tested: Built and run through the unit test suite. Change-Id: Ib7ee90d489d5db72496aaaca91c3cf5490ad47d6 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index a20fe8a..5d81f75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,18 +5,16 @@ libfan_la_LDFLAGS = -static
libfan_la_LIBADD = \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
$(PHOSPHOR_LOGGING_LIBS) \
- $(SDBUSPLUS_LIBS) \
- $(SDEVENTPLUS_LIBS)
+ $(SDBUSPLUS_LIBS)
libfan_la_CXXFLAGS = \
$(PHOSPHOR_DBUS_INTERFACES_CFLAGS) \
$(PHOSPHOR_LOGGING_CFLAGS) \
$(SDBUSPLUS_CFLAGS) \
- $(SDEVENTPLUS_CFLAGS) -flto
+ -flto
libfan_la_SOURCES = \
- utility.cpp \
- timer.cpp
+ utility.cpp
-SUBDIRS = . test sdevent/test evdevpp/test
+SUBDIRS = . sdevent/test evdevpp/test
if WANT_PRESENCE
SUBDIRS += presence
OpenPOWER on IntegriCloud