summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-06-14 07:17:21 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-29 18:36:04 +0000
commita320c7cafcab3a967de9a1149a5e34e02699d382 (patch)
treec676d1b03407a0092d9b25256bbc04ab73a5f32b /configure.ac
parenta19440dc9e62ffc3f8f7d1f46f0801f2b25cd0cf (diff)
downloadphosphor-debug-collector-a320c7cafcab3a967de9a1149a5e34e02699d382.tar.gz
phosphor-debug-collector-a320c7cafcab3a967de9a1149a5e34e02699d382.zip
Implementation of create interface.
Both the external and internal Dump managers define "Create" interfaces. This commit implements these. Change-Id: If857ec6ea7267fd72e9b420e6b44fa68b6abab66 Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 985624c..0807a82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,5 +51,19 @@ AC_ARG_VAR(CORE_FILE_DIR, [Directory where core dumps are placed])
AS_IF([test "x$CORE_FILE_DIR" == "x"], [CORE_FILE_DIR="/var/lib/systemd/coredump"])
AC_DEFINE_UNQUOTED([CORE_FILE_DIR], ["$CORE_FILE_DIR"], [Directory where core dumps are placed])
+AC_ARG_VAR(OBJ_INTERNAL, [Internal Dump manager Dbus object path])
+AS_IF([test "x$OBJ_INTERNAL" == "x"], [OBJ_INTERNAL="/xyz/openbmc_project/dump/internal/manager"])
+AC_DEFINE_UNQUOTED([OBJ_INTERNAL], ["$OBJ_INTERNAL"], [Internal Dump manager Dbus object path])
+
+AC_ARG_VAR(OBJ_ENTRY, [The dump entry DBus object path.])
+AS_IF([test "x$OBJ_ENTRY" == "x"], [OBJ_ENTRY="/xyz/openbmc_project/dump/entry"])
+AC_DEFINE_UNQUOTED([OBJ_ENTRY], ["$OBJ_ENTRY"], [The dump entry DBus object path])
+
+# TODO openbmc/openbmc#1795
+# Change the path to Dump Partition path.
+AC_ARG_VAR(BMC_DUMP_FILE_DIR, [Directory where bmc dumps are placed])
+AS_IF([test "x$BMC_DUMP_FILE_DIR" == "x"], [BMC_DUMP_FILE_DIR="/tmp"])
+AC_DEFINE_UNQUOTED([BMC_DUMP_FILE_DIR], ["$BMC_DUMP_FILE_DIR"], [Directory where bmc dumps are placed])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud