summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-09-04 22:07:06 -0500
committerJayanth Othayoth <ojayanth@in.ibm.com>2017-09-14 06:39:09 +0000
commit2496482acd4df532ebb2850679d2b55680c2ec9f (patch)
treebbe3e54471370d2e5124aa134cfe13b59823032d /configure.ac
parentd0f0064eb989a93e241c599641654f12141ef636 (diff)
downloadphosphor-debug-collector-2496482acd4df532ebb2850679d2b55680c2ec9f.tar.gz
phosphor-debug-collector-2496482acd4df532ebb2850679d2b55680c2ec9f.zip
Enable support to handle InternalFailure type dump, during elog restore
Resolves openbmc/openbmc#2078 Change-Id: Iea47b9b7c0cd6cae21642057b21c4e99d85be1e8 Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00a76bf..fa69297 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,5 +77,11 @@ AC_DEFINE_UNQUOTED([BMC_DUMP_TOTAL_SIZE], [$BMC_DUMP_TOTAL_SIZE], [Total size of
AC_DEFINE(OBJ_LOGGING, "/xyz/openbmc_project/logging", [The log manager DBus object path.])
+AC_ARG_VAR(ELOG_ID_PERSIST_PATH, [Path of file for storing elog id's, which have associated dumps])
+AS_IF([test "x$ELOG_ID_PERSIST_PATH" == "x"], \
+ [ELOG_ID_PERSIST_PATH="/var/lib/phosphor-debug-collector/elogid"])
+AC_DEFINE_UNQUOTED([ELOG_ID_PERSIST_PATH], ["$ELOG_ID_PERSIST_PATH"], \
+ [Path of file for storing elog id's, which have associated dumps])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud