summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-07 23:14:57 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-04 22:40:30 -0400
commitb604480a43a25d0645b944fb16c1268d36782d36 (patch)
tree8732d567daf41e7adb6c32ae71c3fe15c89a914e /src/test/Makefile.am
parent0e7df1317a055fd0a3e15fb46b1e78b6887ee2c8 (diff)
downloadphosphor-dbus-monitor-b604480a43a25d0645b944fb16c1268d36782d36.tar.gz
phosphor-dbus-monitor-b604480a43a25d0645b944fb16c1268d36782d36.zip
Add testcases for path and path group support
Change-Id: I296de0e0cb30e0e25f6677a06bd04fe15c2fd015 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index c44bffa..02772e7 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -11,3 +11,28 @@ BUILT_SOURCES =
CLEANFILES =
TESTS = $(check_PROGRAMS)
+
+check_PROGRAMS += pathgentest
+pathgentest_SOURCES = \
+ pathgentest.cpp
+pathgentest_CXXFLAGS = \
+ $(gtest_cflags)
+pathgentest_LDFLAGS = \
+ $(OESDK_TESTCASE_FLAGS)
+pathgentest_LDADD = \
+ ${gtest_ldadd}
+
+BUILT_SOURCES += pathgentest.hpp
+CLEANFILES += pathgentest.hpp
+
+PATH_TEST_GEN_DEPS = \
+ templates/pathgentest.mako.hpp \
+ yaml/pathgentest
+
+pathgentest.hpp: $(PDMGEN) $(PATH_TEST_GEN_DEPS)
+ $(AM_V_GEN) $(PYTHON) $(PDMGEN) \
+ -t pathgentest.mako.hpp \
+ -p "${TEMPLATESEARCH}" \
+ -d yaml/pathgentest \
+ -o $(builddir)/$@ \
+ generate-cpp
OpenPOWER on IntegriCloud