summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-02-13 15:27:28 -0800
committerPatrick Venture <venture@google.com>2019-02-13 15:27:28 -0800
commit50b4b44aedb2a8e7258516faa8696068ec03eab4 (patch)
tree109900abb6c0925c5f439bb294bccd7c688ecdce
parent12789e6c66cd21ba950c64b09ed1b4d2aae5f0d0 (diff)
downloadphosphor-dbus-monitor-50b4b44aedb2a8e7258516faa8696068ec03eab4.zip
phosphor-dbus-monitor-50b4b44aedb2a8e7258516faa8696068ec03eab4.tar.gz
build: pkg anti-pattern: use defaults
Use the defaults in the pkg check where the default error message is sufficient to identify which package is missing. Change-Id: I16bdbf34b753bdf91dfa4dac824ffd626fd190f7 Signed-off-by: Patrick Venture <venture@google.com>
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1ff3c65..be4f46a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,11 +17,11 @@ AM_PATH_PYTHON([2.7],
[AC_MSG_ERROR([Could not find python-2.7 installed...python-2.7 is required])])
# Checks for libraries.
-PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],, AC_MSG_ERROR(["Requires sdbusplus package."]))
-PKG_CHECK_MODULES([SDEVENTPLUS], [sdeventplus],, AC_MSG_ERROR(["Requires sdeventplus package."]))
-PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],, AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
-PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging],, AC_MSG_ERROR(["Requires phosphor-logging."]))
-PKG_CHECK_MODULES([PHOSPHOR_SNMP], [phosphor-snmp],, AC_MSG_ERROR(["Requires phosphor-snmp."]))
+PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus])
+PKG_CHECK_MODULES([SDEVENTPLUS], [sdeventplus])
+PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces])
+PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging])
+PKG_CHECK_MODULES([PHOSPHOR_SNMP], [phosphor-snmp])
# Check for sdbus++
AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
OpenPOWER on IntegriCloud