summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlistair Popple <alistair@popple.id.au>2017-07-13 16:43:58 +1000
committerAlistair Popple <alistair@popple.id.au>2017-07-13 16:43:58 +1000
commit63c4c233624154d6dcbf21ecab10b4444d332d3c (patch)
tree08e247fd0c402be9970ce3231da04d5b2f9509ad /Makefile.am
parent8990970954a73e7dab9032ef553f98819d5dc93b (diff)
downloadpdbg-63c4c233624154d6dcbf21ecab10b4444d332d3c.tar.gz
pdbg-63c4c233624154d6dcbf21ecab10b4444d332d3c.zip
configure.ac: Detect architecture objcopy parameters
The objcopy parameters required to turn device-tree blobs into elf objects for linking are architecture specific but were hard-coded. This required manual updates to Makefile.am when compiling for other architectures. Instead detect the parameters using an autoconf test. Signed-off-by: Alistair Popple <alistair@popple.id.au>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1db5546..2bd3f83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,5 +60,4 @@ p9w-fsi.dtb.o: p9w-fsi.dts p9-fsi.dtsi
# unflattening the device-tree
dd if=$@.tmp of=$@ ibs=16 conv=sync
rm $@.tmp
-# objcopy -I binary -O elf32-littlearm -B arm $@ $@
- objcopy -I binary -O elf64-x86-64 -B i386:x86-64 $@ $@
+ objcopy -I binary -O @ARCH_FF@ $@ $@
OpenPOWER on IntegriCloud