summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2019-10-08 11:35:55 -0500
committerAdriana Kobylak <anoo@us.ibm.com>2019-10-25 09:20:20 -0500
commitf3dfe65de8487364c21b7b49396cf912821ea339 (patch)
tree97117eca8fcb20c478dfbffa9d7d0a45b9246198 /configure.ac
parent85f25407598494d8f91890df5152501680a067dd (diff)
downloadopenpower-pnor-code-mgmt-f3dfe65de8487364c21b7b49396cf912821ea339.tar.gz
openpower-pnor-code-mgmt-f3dfe65de8487364c21b7b49396cf912821ea339.zip
Move updatesymlinks to new vpnor feature
The updatesymlinks functionality is to support virtual pnor and it does not depend on the filesystem type. Move it to a new vpnor feature so that users can make use of this feature without being tied to UBI, for example on a eMMC that has a combined BMC+PNOR image. Tested: Verified that the witherspoon image contained the new script and service file and that it powered on to the host. Change-Id: Ic5e51dfde81718e5e285f010be67afbd58eac2e1 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b43e50d2f..07cc7de8b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,12 @@ AS_IF([test "x$enable_verify_pnor_signature" == "xyes"], \
[AC_DEFINE([WANT_SIGNATURE_VERIFY],[],[Enable image signature validation.])])
AM_CONDITIONAL([WANT_SIGNATURE_VERIFY_BUILD], [test "x$enable_verify_pnor_signature" == "xyes"])
+# setup virtual pnor support
+AC_ARG_ENABLE([virtual-pnor],
+ AS_HELP_STRING([--enable-virtual-pnor], [Enable support for virtual pnor])
+)
+AM_CONDITIONAL([VIRTUAL_PNOR_ENABLED], [test "x$enable_virtual_pnor" == "xyes"])
+
AC_DEFINE(CHASSIS_STATE_PATH, "/xyz/openbmc_project/state/chassis0",
[The chassis state path.])
AC_DEFINE(CHASSIS_STATE_OBJ, "xyz.openbmc_project.State.Chassis",
OpenPOWER on IntegriCloud