summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-02-21 14:09:49 +0800
committerLei YU <mine260309@gmail.com>2019-03-07 10:45:26 +0800
commitf3ce4337c959001fc764960fe133edbb71c95c5a (patch)
tree41e793e1a1144d50a1fba6c23dac7d2f1b117452 /configure.ac
parent3bd4a17b4e20b4aa95994ef71ec51a684b4fdeee (diff)
downloadopenpower-pnor-code-mgmt-f3ce4337c959001fc764960fe133edbb71c95c5a.tar.gz
openpower-pnor-code-mgmt-f3ce4337c959001fc764960fe133edbb71c95c5a.zip
Refactor: Split item_updater to common and ubi
The existing item_updater is highly coupled with ubifs. It will support static layout and ubi in future. So split the functions in to common ones and ubi specific ones, and move the ubi specific code in ubi dir. 1. Keep common functions and make them virtual for extension. createActiveAssociation() updateFunctionalAssociation() removeAssociation() erase() 2. Create ubi/item_updater_ubi and move other functions into it. 3. Change updateFunctionalAssociation() parameter for future use. To support static layout, a new item_updater_static will be written. Tested: On the last commit of the patch series, run code update and factory reset on Witherspoon and all work fine. Change-Id: I4cc55b31ee3f37c5b27168611305dee8ce02880a Signed-off-by: Lei YU <mine260309@gmail.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f2d87666a..0213ed472 100755
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,14 @@ AC_DEFINE(PNOR_RW_ACTIVE_PATH, "/var/lib/phosphor-software-manager/pnor/rw",
AC_DEFINE(PNOR_PRSV_ACTIVE_PATH, "/var/lib/phosphor-software-manager/pnor/prsv",
[Path to the active preserved pnor partitions])
+# Setup ubifs layout support
+# For now make it default enabled
+AC_ARG_ENABLE([ubifs_layout],
+ AS_HELP_STRING([--disable-ubifs_layout], [Disable ubifs support.]))
+AS_IF([test "x$enable_ubifs_layout" != "xno"], \
+ [AC_DEFINE([UBIFS_LAYOUT],[],[Enable ubifs support.])])
+AM_CONDITIONAL([UBIFS_LAYOUT], [test "x$enable_ubifs_layout" != "xno"])
+
AC_ARG_VAR(ACTIVE_PNOR_MAX_ALLOWED, [The maximum allowed active pnor versions])
AS_IF([test "x$ACTIVE_PNOR_MAX_ALLOWED" == "x"], [ACTIVE_PNOR_MAX_ALLOWED=2])
AC_DEFINE_UNQUOTED([ACTIVE_PNOR_MAX_ALLOWED], [$ACTIVE_PNOR_MAX_ALLOWED], [The maximum allowed active pnor versions])
OpenPOWER on IntegriCloud