summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-03-28 13:33:20 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-03-30 16:45:34 +0000
commitb66ac3ae258f1ee4431f7a09650da1fd208a264c (patch)
tree81c25df8ba8864870b17d5c3cffdc0cad2027b50 /configure.ac
parentfcff414cdf71951336daada85f23e729d5c5abd7 (diff)
downloadopenpower-pnor-code-mgmt-b66ac3ae258f1ee4431f7a09650da1fd208a264c.tar.gz
openpower-pnor-code-mgmt-b66ac3ae258f1ee4431f7a09650da1fd208a264c.zip
ItemUpdater: Create dbus object with version id
Use the same version id as the version manager. For that query the object paths using the mapper and determine if an item updater object has already been created. Note: The mapper currently return the BMC version as well since the interface is the same. To avoid this, a Host-only interface can be used once those are added, and also an association once the association work is finalized. Closes: openbmc/openbmc#1277 Change-Id: I66711ac92a28b7f7ed37006ad6f40de86be1e54c Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 838566e7c..de7c5b798 100755
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,9 @@ AC_ARG_VAR(SOFTWARE_OBJPATH, [The software manager Dbus root])
AS_IF([test "x$SOFTWARE_OBJPATH" == "x"], [SOFTWARE_OBJPATH="/xyz/openbmc_project/software"])
AC_DEFINE_UNQUOTED([SOFTWARE_OBJPATH], ["$SOFTWARE_OBJPATH"], [The software manager Dbus root])
+AC_DEFINE(VERSION_IFACE, "xyz.openbmc_project.Software.Version",
+ [The software version manager interface])
+
AC_DEFINE(BUSNAME_UPDATER, "org.open_power.Software.Host.Updater",
[The item updater DBus busname to own.])
@@ -62,6 +65,13 @@ AC_ARG_VAR(TOC_FILE, [The path to the pnor toc file])
AS_IF([test "x$TOC_FILE" == "x"], [TOC_FILE="/tmp/pnor/pnor.toc"])
AC_DEFINE_UNQUOTED([TOC_FILE], ["$TOC_FILE"], [The path to the pnor toc file])
+AC_DEFINE(MAPPER_BUSNAME, "xyz.openbmc_project.ObjectMapper",
+ [The object mapper busname.])
+AC_DEFINE(MAPPER_PATH, "/xyz/openbmc_project/object_mapper",
+ [The object mapper path.])
+AC_DEFINE(MAPPER_INTERFACE, "xyz.openbmc_project.ObjectMapper",
+ [The object mapper interface.])
+
AC_CONFIG_FILES([Makefile test/Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud