summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSaqib Khan <khansa@us.ibm.com>2017-04-12 10:27:56 -0500
committerSaqib Khan <khansa@us.ibm.com>2017-04-25 20:55:23 -0500
commita8ade7e4620ed2f407a9f6d0c58ce8462bcabbf6 (patch)
tree32be4f86e6b1d04b9fd41f598f15c6d43fa0a11b /configure.ac
parent7254f0ea592464c96181cef2a4b86de52d8ce888 (diff)
downloadopenpower-pnor-code-mgmt-a8ade7e4620ed2f407a9f6d0c58ce8462bcabbf6.tar.gz
openpower-pnor-code-mgmt-a8ade7e4620ed2f407a9f6d0c58ce8462bcabbf6.zip
ItemUpdater: Validate PNOR squashfs image
- Validate the image dir by checking its content. - Set Activation to "Ready" if validation passed or else set it to "Invalid". Resolves openbmc/openbmc#1356 Change-Id: Ica73ae5604e74db11cd58c223d82265309ea76a6 Signed-off-by: Saqib Khan <khansa@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c8c90a782..525370344 100755
--- a/configure.ac
+++ b/configure.ac
@@ -64,9 +64,13 @@ AC_DEFINE(BUSNAME_UPDATER, "org.open_power.Software.Host.Updater",
[The item updater DBus busname to own.])
AC_ARG_VAR(MANIFEST_FILE, [The path to the MANIFEST file])
-AS_IF([test "x$MANIFEST_FILE" == "x"], [MANIFEST_FILE="/tmp/pnor/MANIFEST"])
+AS_IF([test "x$MANIFEST_FILE" == "x"], [MANIFEST_FILE="/tmp/images/MANIFEST"])
AC_DEFINE_UNQUOTED([MANIFEST_FILE], ["$MANIFEST_FILE"], [The path to the MANIFEST file])
+AC_ARG_VAR(IMAGE_DIR, [The path to all the IMAGE files])
+AS_IF([test "x$IMAGE_DIR" == "x"], [IMAGE_DIR="/tmp/images/"])
+AC_DEFINE_UNQUOTED([IMAGE_DIR], ["$IMAGE_DIR"], [The path to all the IMAGE files])
+
AC_DEFINE(MAPPER_BUSNAME, "xyz.openbmc_project.ObjectMapper",
[The object mapper busname.])
AC_DEFINE(MAPPER_PATH, "/xyz/openbmc_project/object_mapper",
OpenPOWER on IntegriCloud