summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGunnar Mills <gmills@us.ibm.com>2017-03-08 15:00:08 -0600
committerGunnar Mills <gmills@us.ibm.com>2017-03-21 14:59:09 -0500
commit9df13162fcf6ea971f5d1b074c4ddfb912d567da (patch)
tree63380b5d619598ad4ac34bc64520d7f1475e2594 /configure.ac
parentf8f113022574ced01dca0a5b78c7c87b235451d2 (diff)
downloadopenpower-pnor-code-mgmt-9df13162fcf6ea971f5d1b074c4ddfb912d567da.tar.gz
openpower-pnor-code-mgmt-9df13162fcf6ea971f5d1b074c4ddfb912d567da.zip
Add base support for PNOR code management
This is the starting code needed to build the application. Change-Id: Ie2937ed6246b8646b9e5b4d09318bc4aa7b31c35 Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100755
index 000000000..eaf171f5a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,37 @@
+AC_PREREQ([2.69])
+AC_INIT([openpower-pnor-code-mgmt], [1.0], [https://github.com/openbmc/openpower-pnor-code-mgmt/issues])
+AC_LANG([C++])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+
+# Checks for programs
+AC_PROG_CXX
+AC_PROG_INSTALL #Checks/sets the install variable to be used
+AC_PROG_MAKE_SET
+
+# Check for libraries
+PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
+ AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
+PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
+ AC_MSG_ERROR(["Requires sdbusplus package."]))
+
+# Checks for library functions
+LT_INIT # Required for systemd linking
+
+# Checks for typedefs, structures, and compiler characteristics.
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+AC_ARG_VAR(VERSION_BUSNAME, [The Dbus busname to own])
+AS_IF([test "x$VERSION_BUSNAME" == "x"],
+ [VERSION_BUSNAME="org.open_power.Software.Host.Version"])
+AC_DEFINE_UNQUOTED([VERSION_BUSNAME], ["$VERSION_BUSNAME"], [The DBus busname to own])
+
+AC_ARG_VAR(SOFTWARE_OBJPATH, [The software manager Dbus root])
+AS_IF([test "x$SOFTWARE_OBJPATH" == "x"], [SOFTWARE_OBJPATH="/xyz/openbmc_project/software"])
+AC_DEFINE_UNQUOTED([SOFTWARE_OBJPATH], ["$SOFTWARE_OBJPATH"], [The software manager Dbus root])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
+
OpenPOWER on IntegriCloud