summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-05-19 09:41:27 -0500
committerAdriana Kobylak <anoo@us.ibm.com>2017-05-31 12:22:55 -0500
commit5ba6b10e0b3622ceb920a07d1094af7607ae5dff (patch)
treea9f4d54ae6d833fc210cc5033cbda88e76e54e95 /configure.ac
parentd6a549ead1875ad10d084d21206ea1b2eeb1b0c6 (diff)
downloadopenpower-pnor-code-mgmt-5ba6b10e0b3622ceb920a07d1094af7607ae5dff.tar.gz
openpower-pnor-code-mgmt-5ba6b10e0b3622ceb920a07d1094af7607ae5dff.zip
item_updater: Use the Common.FilePath.Path to find the image files
The image manager implements the Common.FilePath.Path interface, make use of it to find the image files instead of hardcoding the path, since the updater shouldn't know/care where the images are. Change-Id: Ie9ec5982af1ec2ddd6d7a1b9e69d518520225ab5 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7c9278c12..eeabcfa4e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -54,18 +54,16 @@ AC_DEFINE_UNQUOTED([SOFTWARE_OBJPATH], ["$SOFTWARE_OBJPATH"], [The software mana
AC_DEFINE(VERSION_IFACE, "xyz.openbmc_project.Software.Version",
[The software version manager interface])
+AC_DEFINE(FILEPATH_IFACE, "xyz.openbmc_project.Common.FilePath",
+ [The common file path interface])
AC_DEFINE(BUSNAME_UPDATER, "org.open_power.Software.Host.Updater",
[The item updater DBus busname to own.])
AC_ARG_VAR(MANIFEST_FILE, [The path to the MANIFEST file])
-AS_IF([test "x$MANIFEST_FILE" == "x"], [MANIFEST_FILE="/tmp/images/MANIFEST"])
+AS_IF([test "x$MANIFEST_FILE" == "x"], [MANIFEST_FILE="MANIFEST"])
AC_DEFINE_UNQUOTED([MANIFEST_FILE], ["$MANIFEST_FILE"], [The path to the MANIFEST file])
-AC_ARG_VAR(IMAGE_DIR, [The path to all the IMAGE files])
-AS_IF([test "x$IMAGE_DIR" == "x"], [IMAGE_DIR="/tmp/images/"])
-AC_DEFINE_UNQUOTED([IMAGE_DIR], ["$IMAGE_DIR"], [The path to all the IMAGE files])
-
AC_DEFINE(MAPPER_BUSNAME, "xyz.openbmc_project.ObjectMapper",
[The object mapper busname.])
AC_DEFINE(MAPPER_PATH, "/xyz/openbmc_project/object_mapper",
OpenPOWER on IntegriCloud