summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Tritz <mtritz@us.ibm.com>2017-10-06 16:52:01 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-11-28 01:45:12 +0000
commit5b75651b350476455d3c2b6f948a273b1438a790 (patch)
tree9c107158d2afd46e7ee1d0a1ca74185e5a2e3910 /configure.ac
parent795d984d7113a237939d2d9c1cdbf71146a04144 (diff)
downloadopenpower-pnor-code-mgmt-5b75651b350476455d3c2b6f948a273b1438a790.tar.gz
openpower-pnor-code-mgmt-5b75651b350476455d3c2b6f948a273b1438a790.zip
Host updater: Remove the Object.Delete interface from functional version
This commit enhances the host updater by dynamically removing the Object.Delete interface from a host activation that is currently running. Once the host isn't running anymore, the interface is re-added so that the activation may be deleted. Additionally, isVersionFunctional() from the parent updater is exposed, since this function is needed to determine whether a given activation is currently running on the host. Add the Delete interface to all interfaces when the item updater starts up, because the chassis state would be off initially, and in the case where it automatically powers on because the BMC rebooted while the host was on, the chassis property signal would cause the Delete interface to be removed. Change-Id: I4afcc1ebe2e8a3ce212b426749295e79b68cac62 Signed-off-by: Michael Tritz <mtritz@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4996623b0..96cde53ce 100755
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,13 @@ AC_ARG_VAR(MANIFEST_FILE, [The path to the MANIFEST file])
AS_IF([test "x$MANIFEST_FILE" == "x"], [MANIFEST_FILE="MANIFEST"])
AC_DEFINE_UNQUOTED([MANIFEST_FILE], ["$MANIFEST_FILE"], [The path to the MANIFEST file])
+AC_DEFINE(CHASSIS_STATE_PATH, "/xyz/openbmc_project/state/chassis0",
+ [The chassis state path.])
+AC_DEFINE(CHASSIS_STATE_OBJ, "xyz.openbmc_project.State.Chassis",
+ [The chassis state interface.])
+AC_DEFINE(CHASSIS_STATE_OFF, "xyz.openbmc_project.State.Chassis.PowerState.Off",
+ [The chassis state off property value.])
+
AC_DEFINE(MAPPER_BUSNAME, "xyz.openbmc_project.ObjectMapper",
[The object mapper busname.])
AC_DEFINE(MAPPER_PATH, "/xyz/openbmc_project/object_mapper",
@@ -89,6 +96,8 @@ AC_DEFINE(SYSTEMD_PATH, "/org/freedesktop/systemd1",
[systemd path.])
AC_DEFINE(SYSTEMD_INTERFACE, "org.freedesktop.systemd1.Manager",
[systemd interface.])
+AC_DEFINE(SYSTEMD_PROPERTY_INTERFACE, "org.freedesktop.DBus.Properties",
+ [systemd properties interface.])
AC_DEFINE(PNOR_TOC_FILE, "pnor.toc",
[The name of the PNOR table of contents file])
OpenPOWER on IntegriCloud