summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGunnar Mills <gmills@us.ibm.com>2017-03-20 15:02:27 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-03-29 18:17:11 +0000
commit44c7729b5846c88dc1ed616ebf5c12f7a9ae4c50 (patch)
tree204bd8f83b4483641b6c708ad7e8b1fd1483023a /configure.ac
parent93433f0cf984ae996a81355863803dfcb4917eaf (diff)
downloadopenpower-pnor-code-mgmt-44c7729b5846c88dc1ed616ebf5c12f7a9ae4c50.tar.gz
openpower-pnor-code-mgmt-44c7729b5846c88dc1ed616ebf5c12f7a9ae4c50.zip
Determine the host software id
The id is determined by hashing the PNOR version. For now, assume the pnor partitions are located at /tmp/pnor. Part of openbmc/openbmc#1276. The PNOR version is read from pnor.toc Change-Id: Iddab7bb4ae5c350c60abf93057ddd997c97fa84c Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d51ad37a7..45081dbef 100755
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,8 @@ PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
AC_MSG_ERROR(["Requires sdbusplus package."]))
+PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging],,
+ [AC_MSG_ERROR([The openbmc/phosphor-logging package is required])])
# Checks for library functions
LT_INIT # Required for systemd linking
@@ -35,6 +37,10 @@ AC_DEFINE_UNQUOTED([SOFTWARE_OBJPATH], ["$SOFTWARE_OBJPATH"], [The software mana
AC_DEFINE(BUSNAME_UPDATER, "org.open_power.Software.Host.Updater",
[The item updater DBus busname to own.])
+AC_ARG_VAR(TOC_FILE, [The path to the pnor toc file])
+AS_IF([test "x$TOC_FILE" == "x"], [TOC_FILE="/tmp/pnor/pnor.toc"])
+AC_DEFINE_UNQUOTED([TOC_FILE], ["$TOC_FILE"], [The path to the pnor toc file])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud