summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2018-04-17 10:35:26 -0500
committerAdriana Kobylak <anoo@us.ibm.com>2018-04-17 11:11:15 -0500
commit207469f901a9cd3ea791e9a7bec4d8c697ac479c (patch)
treebf388d8e1708788df9c579b8ba942fd7444a2cba /configure.ac
parenta9cfcedc9a6efdd180a5cfa506a59906deb1372f (diff)
downloadopenpower-pnor-code-mgmt-207469f901a9cd3ea791e9a7bec4d8c697ac479c.tar.gz
openpower-pnor-code-mgmt-207469f901a9cd3ea791e9a7bec4d8c697ac479c.zip
Make the name of the signature verify feature unique
The verify_signature feature name is the same as the one used in the phosphor-software-manager repo which manages the BMC firmware updates. Change the name to make it different to be able to control enabling the feature individually via recipes, since enabling it on the phosphor recipe enables it for the pnor code as well (due to the recipe dependency on virtual-obmc-image-manager). Change-Id: I73e446dd6d5f0995132bc60403e08d16d07703bd Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fd8a17d68..385af263e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -97,11 +97,11 @@ AS_IF([test "x$SIGNATURE_FILE_EXT" == "x"], [SIGNATURE_FILE_EXT=".sig"])
AC_DEFINE_UNQUOTED([SIGNATURE_FILE_EXT], ["$SIGNATURE_FILE_EXT"], [The extension of the Signature file])
# setup signature verification
-AC_ARG_ENABLE([verify_signature],
- AS_HELP_STRING([--enable-verify_signature], [Enable image signature validation.]))
-AS_IF([test "x$enable_verify_signature" == "xyes"], \
+AC_ARG_ENABLE([verify_pnor_signature],
+ AS_HELP_STRING([--enable-verify_pnor_signature], [Enable image signature validation.]))
+AS_IF([test "x$enable_verify_pnor_signature" == "xyes"], \
[AC_DEFINE([WANT_SIGNATURE_VERIFY],[],[Enable image signature validation.])])
-AM_CONDITIONAL([WANT_SIGNATURE_VERIFY_BUILD], [test "x$enable_verify_signature" == "xyes"])
+AM_CONDITIONAL([WANT_SIGNATURE_VERIFY_BUILD], [test "x$enable_verify_pnor_signature" == "xyes"])
AC_DEFINE(CHASSIS_STATE_PATH, "/xyz/openbmc_project/state/chassis0",
[The chassis state path.])
OpenPOWER on IntegriCloud