summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-08-09 21:42:10 +0530
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-08-11 21:15:28 +0530
commitd298105de8ff706e66fe9f45b034219988dd1473 (patch)
tree1c15643a41e297965439f16a51496b50988517d3 /configure.ac
parent30e329add77a72fffeb21e9d3203062a042c6f30 (diff)
downloadopenpower-occ-control-d298105de8ff706e66fe9f45b034219988dd1473.tar.gz
openpower-occ-control-d298105de8ff706e66fe9f45b034219988dd1473.zip
Call Hub FSI scan service prior to doing OCC bind
This is needed to make sure that the /dev/occ files are created that are needed to communicate with OCC device. Also, calling to this service is needed only when the first call to do OCC bind is received. Change-Id: I40466b8b74753b2f2366be385a8b066e912b32e4 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3091e67..098a0eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,10 @@ AC_ARG_VAR(DEV_PATH, [The device path])
AS_IF([test "x$DEV_PATH" == "x"], [DEV_PATH="/sys/bus/platform/devices/"])
AC_DEFINE_UNQUOTED([DEV_PATH], ["$DEV_PATH"], [The device path])
+AC_ARG_VAR(FSI_SCAN_FILE, [The File to write for initiating FSI rescan])
+AS_IF([test "x$FSI_SCAN_FILE" == "x"], [FSI_SCAN_FILE="/sys/devices/platform/gpio-fsi/fsi0/slave@00:00/00:00:00:0a/fsi1/rescan"])
+AC_DEFINE_UNQUOTED([FSI_SCAN_FILE], ["$FSI_SCAN_FILE"], [The File to write for initiating FSI rescan])
+
AC_ARG_VAR(PS_DERATING_FACTOR, [The power supply derating factor])
AS_IF([test "x$PS_DERATING_FACTOR" == "x"], [PS_DERATING_FACTOR=90])
AC_DEFINE_UNQUOTED([PS_DERATING_FACTOR], [$PS_DERATING_FACTOR], [The power supply derating factor])
OpenPOWER on IntegriCloud