summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-03-14 07:17:01 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-03-28 20:54:05 +0000
commit77bc009e86eb30c9c8911d1727beb5923bd02551 (patch)
tree94be5216644a80a6b34fa73e97af7da4995474ba /configure.ac
parent70e4fcf5af8913ba2da4ba7b1a4e77c17adcd6b3 (diff)
downloadopenpower-dbus-interfaces-77bc009e86eb30c9c8911d1727beb5923bd02551.tar.gz
openpower-dbus-interfaces-77bc009e86eb30c9c8911d1727beb5923bd02551.zip
build: autotools files for libopenpower_dbus.so
Use the interface YAML files present to generate the server.cpp and server.hpp files, build them into a shared library, and install. Change-Id: I87217ba299c04b3eb3fac819463707a103a287b5 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f194a38
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,37 @@
+# Initialization
+AC_PREREQ([2.69])
+AC_INIT([openpower-dbus-interfaces], [1.0], [https://github.com/openbmc/openpower-dbus-interfaces])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+AC_LANG([C++])
+
+# Checks for programs.
+AC_PROG_CXX
+AM_PROG_AR
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_PROG_SED
+AC_CHECK_PROG([FIND], find, find)
+AC_CHECK_PROG([BASENAME], basename, basename)
+AC_CHECK_PROG([DIRNAME], dirname, dirname)
+
+AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
+AS_IF([test "x$SDBUSPLUSPLUS" == "x"],
+ AC_MSG_ERROR([Cannot find sdbus++]))
+
+# Check for baseline language coverage in the compiler for the C++14 standard
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CFLAGS])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+# Checks for library functions.
+LT_INIT([dlopen disable-static shared])
+LT_LIB_DLLOAD
+
+# Create configured output
+AC_CONFIG_FILES([Makefile.interfaces],
+ [${srcdir}/generate_makefile.sh ${srcdir} > Makefile.interfaces])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud