summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-02-13 15:04:38 -0800
committerPatrick Venture <venture@google.com>2019-02-13 15:04:38 -0800
commit06fb28bcecb1f1f209bba5ba102e4d88742d0905 (patch)
tree11e68266aca6d21e45dee9b88a56ebb43afb8d30
parent8f51109d8ecd3a396e935a9705b452fdb11cc614 (diff)
downloadipmi-fru-parser-06fb28bcecb1f1f209bba5ba102e4d88742d0905.zip
ipmi-fru-parser-06fb28bcecb1f1f209bba5ba102e4d88742d0905.tar.gz
build: pkg anti-pattern: use defaults
Use the defaults in the pkg check where the default error message is sufficient to identify which package is missing. Change-Id: Iccc91bcdd4ad57980a4731184b448936c1968f85 Signed-off-by: Patrick Venture <venture@google.com>
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 47d3a27..4796d73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,10 +21,8 @@ AM_PATH_PYTHON([2.7],
AC_CHECK_LIB([mapper], [mapper_get_service],,\
[AC_MSG_ERROR([Could not find libmapper: phosphor-objmgr package required])])
PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
-PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,\
- [AC_MSG_ERROR([Requires sdbusplus package.])])
-PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging],,\
- [AC_MSG_ERROR([The openbmc/phosphor-logging package is required])])
+PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus])
+PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging])
# Checks for header files.
AC_CHECK_HEADER(systemd/sd-bus.h, ,[AC_MSG_ERROR([Could not find systemd/sd-bus.h...systemd development package required])])
OpenPOWER on IntegriCloud