summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-03-18 09:06:56 -0700
committerPatrick Venture <venture@google.com>2019-03-18 09:06:56 -0700
commit51372f02b96e1f1b1317e25e956c712019557bb4 (patch)
tree1adfd84f1c11a0d92b04ede6a363efddce5634cf /configure.ac
parenta8356420078bb7e7580fe6c42818e20203c7cbfc (diff)
downloadipmi-blob-tool-51372f02b96e1f1b1317e25e956c712019557bb4.tar.gz
ipmi-blob-tool-51372f02b96e1f1b1317e25e956c712019557bb4.zip
autotools: Fix for autoconf-archive 2019.01.19
The code coverage macros from the archive changed in a backward incompatible way. This adds a workaround to autodetect either version and do the right thing. Change-Id: I4258fab8811f07760ebd73e8ac55c8493370e19b Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b1e8145..12762f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ AC_LANG([C++])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIRS([m4])
AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([nostdinc foreign subdir-objects -Wall -Werror dist-xz tar-ustar])
+AM_INIT_AUTOMAKE([nostdinc foreign subdir-objects -Wall -Wno-portability -Werror dist-xz tar-ustar])
AM_SILENT_RULES([yes])
# Make sure the default CFLAGS of `-O2 -g` don't override CODE_COVERAGE_CFLAGS
@@ -120,10 +120,16 @@ m4_foreach([vgtool], [valgrind_tool_list],
# Code coverage
AX_CODE_COVERAGE
-AM_EXTRA_RECURSIVE_TARGETS([check-code-coverage])
AS_IF([test "x$CODE_COVERAGE_ENABLED" = "xyes"], [
AX_APPEND_COMPILE_FLAGS([-DHAVE_GCOV], [CODE_COVERAGE_CPPFLAGS])
])
+AS_IF([test "x$CODE_COVERAGE_ENABLED" = "xyes"], [
+ AX_APPEND_COMPILE_FLAGS([-DHAVE_GCOV], [CODE_COVERAGE_CPPFLAGS])
+])
+m4_ifdef([_AX_CODE_COVERAGE_RULES],
+ [AM_CONDITIONAL(AUTOCONF_CODE_COVERAGE_2019_01_06, [true])],
+ [AM_CONDITIONAL(AUTOCONF_CODE_COVERAGE_2019_01_06, [false])])
+AX_ADD_AM_MACRO_STATIC([])
# Append -Werror after doing autoconf compiler checks
# Otherwise some perfectly valid checks can fail and cause our
OpenPOWER on IntegriCloud