summaryrefslogtreecommitdiffstats
path: root/package/tstools/tstools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/tstools/tstools.mk')
-rw-r--r--package/tstools/tstools.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/tstools/tstools.mk b/package/tstools/tstools.mk
new file mode 100644
index 0000000000..377cc34f91
--- /dev/null
+++ b/package/tstools/tstools.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# tstools
+#
+################################################################################
+
+TSTOOLS_VERSION = 1_11
+TSTOOLS_SITE = https://tstools.googlecode.com/files/
+TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
+TSTOOLS_LICENSE = MPL v1.1
+
+define TSTOOLS_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define TSTOOLS_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+ DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud