summaryrefslogtreecommitdiffstats
path: root/package/sconeserver/sconeserver.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/sconeserver/sconeserver.mk')
-rw-r--r--package/sconeserver/sconeserver.mk83
1 files changed, 42 insertions, 41 deletions
diff --git a/package/sconeserver/sconeserver.mk b/package/sconeserver/sconeserver.mk
index fd2123def5..d619ad19dd 100644
--- a/package/sconeserver/sconeserver.mk
+++ b/package/sconeserver/sconeserver.mk
@@ -17,99 +17,100 @@ SCONESERVER_CONF_OPTS += --with-ip --with-local
# Sconeserver configure script fails to find the libxml2 headers.
ifeq ($(BR2_PACKAGE_LIBXML2),y)
- SCONESERVER_CONF_OPTS += \
- --with-xml2-config="$(STAGING_DIR)/usr/bin/xml2-config"
+SCONESERVER_CONF_OPTS += \
+ --with-xml2-config="$(STAGING_DIR)/usr/bin/xml2-config"
endif
ifeq ($(BR2_INET_IPV6),y)
- SCONESERVER_CONF_OPTS += --with-ip6
+SCONESERVER_CONF_OPTS += --with-ip6
else
- SCONESERVER_CONF_OPTS += --without-ip6
+SCONESERVER_CONF_OPTS += --without-ip6
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
- SCONESERVER_DEPENDENCIES += openssl
- SCONESERVER_CONF_OPTS += --with-ssl
+SCONESERVER_DEPENDENCIES += openssl
+SCONESERVER_CONF_OPTS += --with-ssl
else
- SCONESERVER_CONF_OPTS += --without-ssl
+SCONESERVER_CONF_OPTS += --without-ssl
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_EXAMPLES),y)
- SCONESERVER_CONF_OPTS += --with-examples
+SCONESERVER_CONF_OPTS += --with-examples
else
- SCONESERVER_CONF_OPTS += --without-examples
+SCONESERVER_CONF_OPTS += --without-examples
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE),y)
- SCONESERVER_DEPENDENCIES += libxml2
- SCONESERVER_CONF_OPTS += --with-sconesite
+SCONESERVER_DEPENDENCIES += libxml2
+SCONESERVER_CONF_OPTS += --with-sconesite
else
- SCONESERVER_CONF_OPTS += --without-sconesite
+SCONESERVER_CONF_OPTS += --without-sconesite
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
- SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
- SCONESERVER_CONF_OPTS += \
- --with-sconesite-image \
- --with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
+SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
+SCONESERVER_CONF_OPTS += \
+ --with-sconesite-image \
+ --with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
else
- SCONESERVER_CONF_OPTS += --without-sconesite-image
+SCONESERVER_CONF_OPTS += --without-sconesite-image
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_MYSQL),y)
- SCONESERVER_DEPENDENCIES += mysql
- SCONESERVER_CONF_OPTS += --with-mysql \
- --with-mysql_config="$(STAGING_DIR)/usr/bin/mysql_config" \
- LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/mysql"
+SCONESERVER_DEPENDENCIES += mysql
+SCONESERVER_CONF_OPTS += \
+ --with-mysql \
+ --with-mysql_config="$(STAGING_DIR)/usr/bin/mysql_config" \
+ LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/mysql"
else
- SCONESERVER_CONF_OPTS += --without-mysql
+SCONESERVER_CONF_OPTS += --without-mysql
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_BLUETOOTH),y)
- SCONESERVER_DEPENDENCIES += bluez_utils
- SCONESERVER_CONF_OPTS += --with-bluetooth
+SCONESERVER_DEPENDENCIES += bluez_utils
+SCONESERVER_CONF_OPTS += --with-bluetooth
else
- SCONESERVER_CONF_OPTS += --without-bluetooth
+SCONESERVER_CONF_OPTS += --without-bluetooth
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_RSS),y)
- SCONESERVER_DEPENDENCIES += libxml2
- SCONESERVER_CONF_OPTS += --with-rss
+SCONESERVER_DEPENDENCIES += libxml2
+SCONESERVER_CONF_OPTS += --with-rss
else
- SCONESERVER_CONF_OPTS += --without-rss
+SCONESERVER_CONF_OPTS += --without-rss
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_LOCATION),y)
- SCONESERVER_DEPENDENCIES += gpsd
- SCONESERVER_CONF_OPTS += --with-location
+SCONESERVER_DEPENDENCIES += gpsd
+SCONESERVER_CONF_OPTS += --with-location
else
- SCONESERVER_CONF_OPTS += --without-location
+SCONESERVER_CONF_OPTS += --without-location
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_LETTUCE),y)
- SCONESERVER_CONF_OPTS += --with-lettuce
+SCONESERVER_CONF_OPTS += --with-lettuce
else
- SCONESERVER_CONF_OPTS += --without-lettuce
+SCONESERVER_CONF_OPTS += --without-lettuce
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_MATHS),y)
- SCONESERVER_DEPENDENCIES += mpfr
- SCONESERVER_CONF_OPTS += --with-maths
+SCONESERVER_DEPENDENCIES += mpfr
+SCONESERVER_CONF_OPTS += --with-maths
else
- SCONESERVER_CONF_OPTS += --without-maths
+SCONESERVER_CONF_OPTS += --without-maths
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_TESTBUILDER),y)
- SCONESERVER_CONF_OPTS += --with-testbuilder
+SCONESERVER_CONF_OPTS += --with-testbuilder
else
- SCONESERVER_CONF_OPTS += --without-testbuilder
+SCONESERVER_CONF_OPTS += --without-testbuilder
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_UI),y)
- SCONESERVER_DEPENDENCIES += xlib_libX11
- SCONESERVER_CONF_OPTS += --with-ui
+SCONESERVER_DEPENDENCIES += xlib_libX11
+SCONESERVER_CONF_OPTS += --with-ui
else
- SCONESERVER_CONF_OPTS += --without-ui
+SCONESERVER_CONF_OPTS += --without-ui
endif
$(eval $(autotools-package))
OpenPOWER on IntegriCloud