summaryrefslogtreecommitdiffstats
path: root/package/rpi-firmware
diff options
context:
space:
mode:
Diffstat (limited to 'package/rpi-firmware')
-rw-r--r--package/rpi-firmware/Config.in86
-rw-r--r--package/rpi-firmware/cmdline.txt1
-rw-r--r--package/rpi-firmware/config.txt20
-rw-r--r--package/rpi-firmware/rpi-firmware.hash2
-rw-r--r--package/rpi-firmware/rpi-firmware.mk48
5 files changed, 0 insertions, 157 deletions
diff --git a/package/rpi-firmware/Config.in b/package/rpi-firmware/Config.in
deleted file mode 100644
index 0ebbe7a4cd..0000000000
--- a/package/rpi-firmware/Config.in
+++ /dev/null
@@ -1,86 +0,0 @@
-config BR2_PACKAGE_RPI_FIRMWARE
- bool "rpi-firmware"
- depends on BR2_arm || BR2_aarch64
- help
- RaspberryPi Firmware
-
- Pre-compiled binaries of the current bootloader and GPU
- firmware
-
- https://github.com/raspberrypi/firmware
-
-if BR2_PACKAGE_RPI_FIRMWARE
-
-choice
- bool "Firmware to boot"
- default BR2_PACKAGE_RPI_FIRMWARE_DEFAULT
- help
- There are three different firmware files:
- - the default firmware, that enables standard GPU
- features;
- - the extended firmware, that enables additional GPU
- features (eg. more audio/video codecs);
- - the cut-down firmware, for emergency situations, with
- only features required to boot a Linux kernel.
-
-config BR2_PACKAGE_RPI_FIRMWARE_DEFAULT
- bool "default"
- help
- The default firmware, that enables standard GPU features.
-
-config BR2_PACKAGE_RPI_FIRMWARE_X
- bool "extended ('x', more codecs)"
- help
- The extended firmware, that enables additional GPU features
- (eg. more audio/video codecs).
-
-config BR2_PACKAGE_RPI_FIRMWARE_CD
- bool "cut-down ('cd', emergency)"
- help
- The cut-down firmware, for emergency situations, with only
- features required to boot a Linux kernel.
-
-endchoice
-
-config BR2_PACKAGE_RPI_FIRMWARE_BOOT
- string
- default "" if BR2_PACKAGE_RPI_FIRMWARE_DEFAULT
- default "_x" if BR2_PACKAGE_RPI_FIRMWARE_X
- default "_cd" if BR2_PACKAGE_RPI_FIRMWARE_CD
-
-config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTBS
- bool "Install Device Tree Blobs (DTBs)"
- default y
- depends on !BR2_LINUX_KERNEL_DTS_SUPPORT
- help
- If you are using a Linux kernel <= 3.18, you should say 'y'
- here.
-
- If you are using a Linux kernel >= 3.19, you should say 'n'
- here, and enable BR2_LINUX_KERNEL_DTS_SUPPORT to let the
- kernel build the DTB.
-
-config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTB_OVERLAYS
- bool "Install DTB overlays"
- default y
- depends on BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTBS \
- || BR2_LINUX_KERNEL_DTS_SUPPORT
- help
- Say 'y' here if you need to load one or more of the DTB
- overlays, to support HATs (Hardware Attached on Top, add-on
- modules).
-
-config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG
- bool "vcdbg"
- depends on BR2_arm # prebuilt arm binary, rpi-userland
- depends on BR2_TOOLCHAIN_USES_GLIBC
- depends on BR2_INSTALL_LIBSTDCPP # rpi-userland
- select BR2_PACKAGE_RPI_USERLAND
- help
- Install vcdbg, to help debug communication with the GPU.
-
-comment "vcdbg needs a glibc toolchain w/ C++"
- depends on BR2_arm
- depends on !BR2_TOOLCHAIN_USES_GLIBC || !BR2_INSTALL_LIBSTDCPP
-
-endif # BR2_PACKAGE_RPI_FIRMWARE
diff --git a/package/rpi-firmware/cmdline.txt b/package/rpi-firmware/cmdline.txt
deleted file mode 100644
index 155a54693b..0000000000
--- a/package/rpi-firmware/cmdline.txt
+++ /dev/null
@@ -1 +0,0 @@
-root=/dev/mmcblk0p2 rootwait console=tty1 console=ttyAMA0,115200
diff --git a/package/rpi-firmware/config.txt b/package/rpi-firmware/config.txt
deleted file mode 100644
index 58cc966a87..0000000000
--- a/package/rpi-firmware/config.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-# Please note that this is only a sample, we recommend you to change it to fit
-# your needs.
-# You should override this file using a post-build script.
-# See http://buildroot.org/manual.html#rootfs-custom
-# and http://elinux.org/RPiconfig for a description of config.txt syntax
-
-kernel=zImage
-
-# To use an external initramfs file
-#initramfs rootfs.cpio.gz
-
-# Disable overscan assuming the display supports displaying the full resolution
-# If the text shown on the screen disappears off the edge, comment this out
-disable_overscan=1
-
-# How much memory in MB to assign to the GPU on Pi models having
-# 256, 512 or 1024 MB total memory
-gpu_mem_256=100
-gpu_mem_512=100
-gpu_mem_1024=100
diff --git a/package/rpi-firmware/rpi-firmware.hash b/package/rpi-firmware/rpi-firmware.hash
deleted file mode 100644
index 9988dda717..0000000000
--- a/package/rpi-firmware/rpi-firmware.hash
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed
-sha256 f1d631920ed4ae15f368ba7b8b3caa4ed604f5223372cc6debbd39a101eb8d74 rpi-firmware-81cca1a9380c828299e884dba5efd0d4acb39e8d.tar.gz
diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
deleted file mode 100644
index e41b3442e6..0000000000
--- a/package/rpi-firmware/rpi-firmware.mk
+++ /dev/null
@@ -1,48 +0,0 @@
-################################################################################
-#
-# rpi-firmware
-#
-################################################################################
-
-RPI_FIRMWARE_VERSION = 81cca1a9380c828299e884dba5efd0d4acb39e8d
-RPI_FIRMWARE_SITE = $(call github,raspberrypi,firmware,$(RPI_FIRMWARE_VERSION))
-RPI_FIRMWARE_LICENSE = BSD-3-Clause
-RPI_FIRMWARE_LICENSE_FILES = boot/LICENCE.broadcom
-RPI_FIRMWARE_INSTALL_IMAGES = YES
-
-ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTBS),y)
-define RPI_FIRMWARE_INSTALL_DTB
- $(foreach dtb,$(wildcard $(@D)/boot/*.dtb), \
- $(INSTALL) -D -m 0644 $(dtb) $(BINARIES_DIR)/rpi-firmware/$(notdir $(dtb))
- )
-endef
-endif
-
-ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTB_OVERLAYS),y)
-define RPI_FIRMWARE_INSTALL_DTB_OVERLAYS
- for ovldtb in $(@D)/boot/overlays/*.dtbo; do \
- $(INSTALL) -D -m 0644 $${ovldtb} $(BINARIES_DIR)/rpi-firmware/overlays/$${ovldtb##*/} || exit 1; \
- done
-endef
-endif
-
-ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_VCDBG),y)
-define RPI_FIRMWARE_INSTALL_TARGET_CMDS
- $(INSTALL) -D -m 0700 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/bin/vcdbg \
- $(TARGET_DIR)/usr/sbin/vcdbg
- $(INSTALL) -D -m 0644 $(@D)/$(if BR2_ARM_EABIHF,hardfp/)opt/vc/lib/libelftoolchain.so \
- $(TARGET_DIR)/usr/lib/libelftoolchain.so
-endef
-endif # INSTALL_VCDBG
-
-define RPI_FIRMWARE_INSTALL_IMAGES_CMDS
- $(INSTALL) -D -m 0644 $(@D)/boot/bootcode.bin $(BINARIES_DIR)/rpi-firmware/bootcode.bin
- $(INSTALL) -D -m 0644 $(@D)/boot/start$(BR2_PACKAGE_RPI_FIRMWARE_BOOT).elf $(BINARIES_DIR)/rpi-firmware/start.elf
- $(INSTALL) -D -m 0644 $(@D)/boot/fixup$(BR2_PACKAGE_RPI_FIRMWARE_BOOT).dat $(BINARIES_DIR)/rpi-firmware/fixup.dat
- $(INSTALL) -D -m 0644 package/rpi-firmware/config.txt $(BINARIES_DIR)/rpi-firmware/config.txt
- $(INSTALL) -D -m 0644 package/rpi-firmware/cmdline.txt $(BINARIES_DIR)/rpi-firmware/cmdline.txt
- $(RPI_FIRMWARE_INSTALL_DTB)
- $(RPI_FIRMWARE_INSTALL_DTB_OVERLAYS)
-endef
-
-$(eval $(generic-package))
OpenPOWER on IntegriCloud