summaryrefslogtreecommitdiffstats
path: root/package/python3/0028-Add-an-option-to-disable-the-readline-module.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python3/0028-Add-an-option-to-disable-the-readline-module.patch')
-rw-r--r--package/python3/0028-Add-an-option-to-disable-the-readline-module.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/python3/0028-Add-an-option-to-disable-the-readline-module.patch b/package/python3/0028-Add-an-option-to-disable-the-readline-module.patch
new file mode 100644
index 0000000000..0c504515a0
--- /dev/null
+++ b/package/python3/0028-Add-an-option-to-disable-the-readline-module.patch
@@ -0,0 +1,30 @@
+From 57e9ef788c27a112b79e489b375882f66f818b0a Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Tue, 7 Mar 2017 23:29:05 +0100
+Subject: [PATCH] Add an option to disable the readline module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index af12c09..64dadb4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3138,6 +3138,12 @@ AC_ARG_ENABLE(openssl,
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
+ fi])
+
++AC_ARG_ENABLE(readline,
++ AS_HELP_STRING([--disable-readline], [disable readline]),
++ [ if test "$enableval" = "no"; then
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} readline"
++ fi])
++
+ AC_SUBST(TK)
+ AC_ARG_ENABLE(tk,
+ AS_HELP_STRING([--disable-tk], [disable tk]),
+--
+2.9.3
+
OpenPOWER on IntegriCloud