summaryrefslogtreecommitdiffstats
path: root/package/python3/0015-Add-an-option-to-disable-lib2to3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python3/0015-Add-an-option-to-disable-lib2to3.patch')
-rw-r--r--package/python3/0015-Add-an-option-to-disable-lib2to3.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/package/python3/0015-Add-an-option-to-disable-lib2to3.patch b/package/python3/0015-Add-an-option-to-disable-lib2to3.patch
index fc44e6f938..e6a39383e5 100644
--- a/package/python3/0015-Add-an-option-to-disable-lib2to3.patch
+++ b/package/python3/0015-Add-an-option-to-disable-lib2to3.patch
@@ -1,4 +1,4 @@
-From a60b0237cb8eb1899b5c4dcf71527437e79972c9 Mon Sep 17 00:00:00 2001
+From c2d279b4a19de7a32e8a73e320423f699d408380 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Wed, 22 Feb 2017 17:15:31 -0800
Subject: [PATCH] Add an option to disable lib2to3
@@ -17,10 +17,10 @@ Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
3 files changed, 21 insertions(+), 6 deletions(-)
diff --git a/Makefile.pre.in b/Makefile.pre.in
-index 92315f2..8e67c91 100644
+index badb2af35d..931cc3ed07 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -1165,7 +1165,9 @@ ifeq (@PYDOC@,yes)
+@@ -1168,7 +1168,9 @@ ifeq (@PYDOC@,yes)
(cd $(DESTDIR)$(BINDIR); $(LN) -s pydoc$(VERSION) pydoc3)
endif
-rm -f $(DESTDIR)$(BINDIR)/2to3
@@ -30,7 +30,7 @@ index 92315f2..8e67c91 100644
-rm -f $(DESTDIR)$(BINDIR)/pyvenv
(cd $(DESTDIR)$(BINDIR); $(LN) -s pyvenv-$(VERSION) pyvenv)
if test "x$(LIPO_32BIT_FLAGS)" != "x" ; then \
-@@ -1202,7 +1204,6 @@ LIBSUBDIRS= tkinter site-packages \
+@@ -1205,7 +1207,6 @@ LIBSUBDIRS= tkinter site-packages \
html json http dbm xmlrpc \
sqlite3 \
logging csv wsgiref urllib \
@@ -38,7 +38,7 @@ index 92315f2..8e67c91 100644
ctypes ctypes/macholib \
idlelib idlelib/Icons \
distutils distutils/command $(XMLLIBSUBDIRS) \
-@@ -1252,9 +1253,6 @@ TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
+@@ -1255,9 +1256,6 @@ TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
test/test_email test/test_email/data \
test/test_json \
sqlite3/test \
@@ -48,7 +48,7 @@ index 92315f2..8e67c91 100644
ctypes/test \
idlelib/idle_test \
distutils/tests \
-@@ -1264,6 +1262,14 @@ TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
+@@ -1267,6 +1265,14 @@ TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
test/test_tools test/test_warnings test/test_warnings/data \
unittest/test unittest/test/testmock
@@ -63,7 +63,7 @@ index 92315f2..8e67c91 100644
ifeq (@TEST_MODULES@,yes)
LIBSUBDIRS += $(TESTSUBDIRS)
endif
-@@ -1363,10 +1369,12 @@ ifeq (@PYC_BUILD@,yes)
+@@ -1366,10 +1372,12 @@ ifeq (@PYC_BUILD@,yes)
-d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
endif
@@ -77,10 +77,10 @@ index 92315f2..8e67c91 100644
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
# Substitution happens here, as the completely-expanded BINDIR
diff --git a/configure.ac b/configure.ac
-index 654594a..b518cbe 100644
+index 1621fa1611..13b2edf8b7 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -3093,6 +3093,12 @@ AC_ARG_ENABLE(test-modules,
+@@ -3124,6 +3124,12 @@ AC_ARG_ENABLE(test-modules,
AS_HELP_STRING([--disable-test-modules], [disable test modules]),
[ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
@@ -94,10 +94,10 @@ index 654594a..b518cbe 100644
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
AC_MSG_CHECKING([if --enable-ipv6 is specified])
diff --git a/setup.py b/setup.py
-index 26bf414..80ec79b 100644
+index 94dd337fef..76429e1326 100644
--- a/setup.py
+++ b/setup.py
-@@ -2279,10 +2279,11 @@ def main():
+@@ -2282,10 +2282,11 @@ def main():
import warnings
warnings.filterwarnings("ignore",category=DeprecationWarning)
@@ -112,5 +112,5 @@ index 26bf414..80ec79b 100644
setup(# PyPI Metadata (PEP 301)
name = "Python",
--
-2.9.3
+2.13.5
OpenPOWER on IntegriCloud