summaryrefslogtreecommitdiffstats
path: root/package/python-web2py/python-web2py.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/python-web2py/python-web2py.mk')
-rw-r--r--package/python-web2py/python-web2py.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/python-web2py/python-web2py.mk b/package/python-web2py/python-web2py.mk
index 313114ad69..db9ed8dfd8 100644
--- a/package/python-web2py/python-web2py.mk
+++ b/package/python-web2py/python-web2py.mk
@@ -32,8 +32,16 @@ define PYTHON_WEB2PY_INSTALL_INIT_SYSTEMD
$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/web2py.service
endef
+# www-data user and group are used for web2py. Because these user and group
+# are already set by buildroot, it is not necessary to redefine them.
+# See system/skeleton/etc/passwd
+# username: www-data uid: 33
+# groupname: www-data gid: 33
+#
+# So, we just need to create the directories used by web2py with the right
+# ownership.
define PYTHON_WEB2PY_PERMISSIONS
- /var/www/web2py r 750 www-data www-data - - - - -
+ /var/www/web2py r 750 33 33 - - - - -
endef
$(eval $(generic-package))
OpenPOWER on IntegriCloud