summaryrefslogtreecommitdiffstats
path: root/package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch')
-rw-r--r--package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch b/package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch
new file mode 100644
index 0000000000..b91ed4fef9
--- /dev/null
+++ b/package/oracle-mysql/0004-Fix-gen_lex_hash-execution.patch
@@ -0,0 +1,32 @@
+Makefile: fix cross-compiling the server
+
+MySQL Makefile believes it can run code it just compiled, to
+generate a header. This does not work for cross-compilation.
+
+Instead, use a pre-installed host-version of the required tool.
+
+Signed-off-by: Marcelo Gutierrez (UTN/FRH) <kuyurix@gmail.com>
+
+--- mysql-5.1.70/sql/Makefile.am
++++ mysql-5.1.70.patch/sql/Makefile.am
+@@ -177,7 +177,7 @@
+ # this avoid the rebuild of the built files in a source dist
+ lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@-t
++ gen_lex_hash$(EXEEXT) > $@-t
+ $(MV) $@-t $@
+
+ # For testing of udf_example.so
+
+--- mysql-5.1.70/sql/Makefile.in
++++ mysql-5.1.70.patch/sql/Makefile.in
+@@ -1310,7 +1310,7 @@
+ # this avoid the rebuild of the built files in a source dist
+ lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@-t
++ gen_lex_hash$(EXEEXT) > $@-t
+ $(MV) $@-t $@
+
+ # We might have some stuff not built in this build, but that we want to install
OpenPOWER on IntegriCloud