summaryrefslogtreecommitdiffstats
path: root/package/gqrx/gqrx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/gqrx/gqrx.mk')
-rw-r--r--package/gqrx/gqrx.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/gqrx/gqrx.mk b/package/gqrx/gqrx.mk
index b51bb23eaf..d93c07d10c 100644
--- a/package/gqrx/gqrx.mk
+++ b/package/gqrx/gqrx.mk
@@ -12,4 +12,10 @@ GQRX_DEPENDENCIES = boost gnuradio gr-osmosdr qt5base qt5svg
GQRX_CONF_OPTS = -DLINUX_AUDIO_BACKEND=Gr-audio
+# gqrx can use __atomic builtins, so we need to link with
+# libatomic when available
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+GQRX_CONF_OPTS += -DCMAKE_EXE_LINKER_FLAGS=-latomic
+endif
+
$(eval $(cmake-package))
OpenPOWER on IntegriCloud