summaryrefslogtreecommitdiffstats
path: root/package/fbgrab/0001-fix-static-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/fbgrab/0001-fix-static-build.patch')
-rw-r--r--package/fbgrab/0001-fix-static-build.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/fbgrab/0001-fix-static-build.patch b/package/fbgrab/0001-fix-static-build.patch
new file mode 100644
index 0000000000..fe5ae2cab1
--- /dev/null
+++ b/package/fbgrab/0001-fix-static-build.patch
@@ -0,0 +1,21 @@
+Fix static build
+
+fbgrab links against libpng, which depends on libm. For shared library
+builds, there is nothing special to do about this, but for static
+library builds, it is necessary to pass -lm when linking fbgrab.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@
+ all: fbgrab fbgrab.1.gz
+
+ fbgrab: fbgrab.c
+- $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) $< -lpng -lz -o $@
++ $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) $< -lpng -lz -lm -o $@
+
+ fbgrab.1.gz: fbgrab.1.man
+ $(GZIP) $(GZIPFLAGS) $< > $@
OpenPOWER on IntegriCloud