summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/ext2/ext2.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index 902e6639ee..5439e2b993 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -29,7 +29,11 @@ ROOTFS_EXT2_DEPENDENCIES = host-e2fsprogs
define ROOTFS_EXT2_CMD
rm -f $@
$(HOST_DIR)/sbin/mkfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN) $(EXT2_OPTS) $@ \
- "$(EXT2_SIZE)"
+ "$(EXT2_SIZE)" \
+ || { ret=$$?; \
+ echo "*** Maybe you need to increase the filesystem size (BR2_TARGET_ROOTFS_EXT2_SIZE)" 1>&2; \
+ exit $$ret; \
+ }
endef
rootfs-ext2-symlink:
OpenPOWER on IntegriCloud