summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-07-26 00:05:28 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-07-26 00:53:05 +0200
commita67f4c3e29349bcb4cc2ac16d23603d4528b50fb (patch)
tree0899cdcc39c73a9dc3f62315e811823122287a0a /fs
parent26b22b85a4bb6608a0fab5dd319d96c86fe7ea76 (diff)
downloadbuildroot-a67f4c3e29349bcb4cc2ac16d23603d4528b50fb.tar.gz
buildroot-a67f4c3e29349bcb4cc2ac16d23603d4528b50fb.zip
fs/ext2: hint about setting the filesystem size on error
Since we now request that the user sets the exact size of the ext2/3/4 filesystem, we've had quite a few users wondering what was going on when they enable too much and the default 60M are no longer enough. When mkfs.ext2 fails, print a hint that the user should check the size setting. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> [Arnout: Add *** and redirect to stderr] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'fs')
-rw-r--r--fs/ext2/ext2.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index 902e6639ee..5439e2b993 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -29,7 +29,11 @@ ROOTFS_EXT2_DEPENDENCIES = host-e2fsprogs
define ROOTFS_EXT2_CMD
rm -f $@
$(HOST_DIR)/sbin/mkfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN) $(EXT2_OPTS) $@ \
- "$(EXT2_SIZE)"
+ "$(EXT2_SIZE)" \
+ || { ret=$$?; \
+ echo "*** Maybe you need to increase the filesystem size (BR2_TARGET_ROOTFS_EXT2_SIZE)" 1>&2; \
+ exit $$ret; \
+ }
endef
rootfs-ext2-symlink:
OpenPOWER on IntegriCloud