summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--linux/linux.mk2
-rw-r--r--package/freescale-imx/Config.in1
-rw-r--r--package/freescale-imx/kernel-module-imx-gpu-viv/Config.in14
-rw-r--r--package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash2
-rw-r--r--package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk20
5 files changed, 39 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 3c53a0bc05..c9986cd8a9 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -251,6 +251,8 @@ define LINUX_KCONFIG_FIXUP_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
+ $(if $(BR2_PACKAGE_KERNEL_MODULE_IMX_GPU_VIV),
+ $(call KCONFIG_DISABLE_OPT,CONFIG_MXC_GPU_VIV,$(@D)/.config))
endef
ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT),y)
diff --git a/package/freescale-imx/Config.in b/package/freescale-imx/Config.in
index a958dbd444..dfb6cc4a3f 100644
--- a/package/freescale-imx/Config.in
+++ b/package/freescale-imx/Config.in
@@ -52,6 +52,7 @@ source "package/freescale-imx/libz160/Config.in"
endif
if BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX6Q
source "package/freescale-imx/imx-gpu-viv/Config.in"
+source "package/freescale-imx/kernel-module-imx-gpu-viv/Config.in"
endif
endif
diff --git a/package/freescale-imx/kernel-module-imx-gpu-viv/Config.in b/package/freescale-imx/kernel-module-imx-gpu-viv/Config.in
new file mode 100644
index 0000000000..bcc55175bc
--- /dev/null
+++ b/package/freescale-imx/kernel-module-imx-gpu-viv/Config.in
@@ -0,0 +1,14 @@
+comment "kernel-module-imx-gpu-viv needs a Linux kernel to be built"
+ depends on !BR2_LINUX_KERNEL
+
+config BR2_PACKAGE_KERNEL_MODULE_IMX_GPU_VIV
+ bool "kernel-module-imx-gpu-viv"
+ depends on BR2_LINUX_KERNEL
+ help
+ Kernel loadable module for Vivante GPU.
+
+ This package uses an exact copy of the GPU kernel driver source code
+ of the same version as base and include fixes and improvements
+ developed by FSL Community
+
+ https://github.com/Freescale/kernel-module-imx-gpu-viv
diff --git a/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash
new file mode 100644
index 0000000000..7d01afbed7
--- /dev/null
+++ b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.hash
@@ -0,0 +1,2 @@
+# locally computed
+sha256 955037fd86d31cdddaed15c254f377f4b30a8abcf5a5e4f9185bd660ff14b7c3 kernel-module-imx-gpu-viv-eeeb23c0fb1cee01318088d417025263479c44ac.tar.gz
diff --git a/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk
new file mode 100644
index 0000000000..95b0a6bd9b
--- /dev/null
+++ b/package/freescale-imx/kernel-module-imx-gpu-viv/kernel-module-imx-gpu-viv.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# kernel-module-imx-gpu-viv
+#
+################################################################################
+
+KERNEL_MODULE_IMX_GPU_VIV_VERSION = eeeb23c0fb1cee01318088d417025263479c44ac
+KERNEL_MODULE_IMX_GPU_VIV_SITE = \
+ $(call github,Freescale,kernel-module-imx-gpu-viv,$(KERNEL_MODULE_IMX_GPU_VIV_VERSION))
+KERNEL_MODULE_IMX_GPU_VIV_LICENSE = GPLv2
+KERNEL_MODULE_IMX_GPU_VIV_LICENSE_FILES = COPYING
+
+KERNEL_MODULE_IMX_GPU_VIV_MODULE_MAKE_OPTS = \
+ AQROOT=$(@D)/kernel-module-imx-gpu-viv-src \
+ KERNEL_DIR=$(LINUX_DIR)
+
+KERNEL_MODULE_IMX_GPU_VIV_MODULE_SUBDIRS = kernel-module-imx-gpu-viv-src
+
+$(eval $(kernel-module))
+$(eval $(generic-package))
OpenPOWER on IntegriCloud