summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/opus/Config.in11
-rw-r--r--package/opus/opus.mk2
2 files changed, 12 insertions, 1 deletions
diff --git a/package/opus/Config.in b/package/opus/Config.in
index 12bdfbbdb3..22e7a5534b 100644
--- a/package/opus/Config.in
+++ b/package/opus/Config.in
@@ -13,3 +13,14 @@ config BR2_PACKAGE_OPUS
quality stereo music.
http://opus-codec.org
+
+if BR2_PACKAGE_OPUS
+
+config BR2_PACKAGE_OPUS_FIXED_POINT
+ bool "use fixed-point" if !BR2_SOFT_FLOAT
+ default y if BR2_SOFT_FLOAT
+ help
+ Compile without floating point operations (for machines
+ without a fast enough FPU).
+
+endif
diff --git a/package/opus/opus.mk b/package/opus/opus.mk
index 007cf16d89..1fc1048454 100644
--- a/package/opus/opus.mk
+++ b/package/opus/opus.mk
@@ -12,7 +12,7 @@ OPUS_INSTALL_STAGING = YES
OPUS_CONF_OPT = --disable-doc
OPUS_AUTORECONF = YES
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(BR2_PACKAGE_OPUS_FIXED_POINT),y)
OPUS_CONF_OPT += --enable-fixed-point
endif
OpenPOWER on IntegriCloud