summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in13
-rw-r--r--Config.in.legacy8
-rw-r--r--boot/grub2/grub2.mk2
-rw-r--r--package/kexec/kexec.mk2
4 files changed, 12 insertions, 13 deletions
diff --git a/Config.in b/Config.in
index 86e10bbe15..72ceadfde6 100644
--- a/Config.in
+++ b/Config.in
@@ -414,13 +414,10 @@ config BR2_DEBUG_3
endchoice
endif
-choice
- prompt "strip command for binaries on target"
- default BR2_STRIP_strip
-
config BR2_STRIP_strip
- bool "strip"
+ bool "strip target binaries"
depends on !BR2_PACKAGE_HOST_ELF2FLT
+ default y
help
Binaries and libraries in the target filesystem will be
stripped using the normal 'strip' command. This allows to save
@@ -428,12 +425,6 @@ config BR2_STRIP_strip
on the target are needed for native debugging, but not when
remote debugging is used.
-config BR2_STRIP_none
- bool "none"
- help
- Do not strip binaries and libraries in the target filesystem.
-endchoice
-
config BR2_STRIP_EXCLUDE_FILES
string "executables that should not be stripped"
depends on BR2_STRIP_strip
diff --git a/Config.in.legacy b/Config.in.legacy
index ec28da3a2a..453c5eb8b8 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -145,6 +145,14 @@ endif
###############################################################################
comment "Legacy options removed in 2017.08"
+config BR2_STRIP_none
+ bool "Strip command 'none' has been removed"
+ select BR2_LEGACY
+ help
+ The strip command choice has been changed into a single
+ boolean option. Please check that the new setting is
+ correct (in the "Build options" sub-menu)
+
config BR2_PACKAGE_BEECRYPT_CPP
bool "C++ support removed in beecrypt"
select BR2_LEGACY
diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index dc019835ab..aa3f4dd8cb 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -46,7 +46,7 @@ endif
# bootloader itself; none of these are used to build the native
# tools.
#
-# NOTE: TARGET_STRIP is overridden by BR2_STRIP_none, so always
+# NOTE: TARGET_STRIP is overridden by !BR2_STRIP_strip, so always
# use the cross compile variant to ensure grub2 builds
GRUB2_CONF_ENV = \
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index 7564103bfc..dd67eab0ca 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -10,7 +10,7 @@ KEXEC_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kernel/kexec
KEXEC_LICENSE = GPL-2.0
KEXEC_LICENSE_FILES = COPYING
-# Makefile expects $STRIP -o to work, so needed for BR2_STRIP_none
+# Makefile expects $STRIP -o to work, so needed for !BR2_STRIP_strip
KEXEC_MAKE_OPTS = STRIP="$(TARGET_CROSS)strip"
ifeq ($(BR2_PACKAGE_KEXEC_ZLIB),y)
OpenPOWER on IntegriCloud