summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2016-02-03 22:45:28 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-03 23:46:00 +0100
commit335f331ff29b825686d74ebb33e59bc400855c82 (patch)
tree0cee899e3ac20316406c5742ed285394842d1b4e /toolchain
parentc2174c1ae47ef3db83b453d16c51aa30308c2e14 (diff)
downloadbuildroot-335f331ff29b825686d74ebb33e59bc400855c82.tar.gz
buildroot-335f331ff29b825686d74ebb33e59bc400855c82.zip
toolchain: copy_toolchain_lib_root: rename LIBSPATH to LIBPATHS
LIBSPATH is populated based on a find with a pattern that can look like: libfoo*.so and thus the output of the find will contain all file paths that match this pattern. Unfortunately, the name LIBSPATH suggests that only one entry is returned, rather than possibly multiple. As this code is quite complex, use the more accurate name LIBPATHS iso LIBSPATH. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/helpers.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 02cc0bb174..ee878e89a1 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -55,13 +55,13 @@ copy_toolchain_lib_root = \
$${ARCH_SYSROOT_DIR}/$${ARCH_LIB_DIR} \
$${ARCH_SYSROOT_DIR}/usr/$${ARCH_LIB_DIR} \
$${SUPPORT_LIB_DIR} ; do \
- LIBSPATH=`find $${dir} -maxdepth 1 -name "$${LIB}" 2>/dev/null` ; \
- if test -n "$${LIBSPATH}" ; then \
+ LIBPATHS=`find $${dir} -maxdepth 1 -name "$${LIB}" 2>/dev/null` ; \
+ if test -n "$${LIBPATHS}" ; then \
break ; \
fi \
done ; \
mkdir -p $(TARGET_DIR)/$${DESTDIR}; \
- for LIBPATH in $${LIBSPATH} ; do \
+ for LIBPATH in $${LIBPATHS} ; do \
while true ; do \
LIBNAME=`basename $${LIBPATH}`; \
LIBDIR=`dirname $${LIBPATH}` ; \
OpenPOWER on IntegriCloud