summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-15 15:40:30 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-15 15:40:30 +0100
commit23ecfd04e6987879b5b4fce8f89b1e6501d011f8 (patch)
tree3e7d48c86a3028ba97df292672d4efb4bfb80665 /toolchain
parent87dd38a939d53edcb3c9e866cf5e766d1033f849 (diff)
downloadbuildroot-23ecfd04e6987879b5b4fce8f89b1e6501d011f8.tar.gz
buildroot-23ecfd04e6987879b5b4fce8f89b1e6501d011f8.zip
toolchain-external: fix support for non-ADI Blackfin external toolchains
The computation of TOOLCHAIN_EXTERNAL_BIN has a special case for Blackfin, where it's set to $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/$(TOOLCHAIN_EXTERNAL_PREFIX)/bin instead of $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/bin for other architectures. However, this is actually only true for Analog Devices pre-built toolchains. Other Blackfin external toolchains (such as ones built by Buildroot) do not have this special organization. Therefore, in order to make those non-ADI Blackfin toolchains work, we need to change the condition from BR2_bfin to testing specifically for the ADI toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/toolchain-external.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/toolchain-external/toolchain-external.mk b/toolchain/toolchain-external/toolchain-external.mk
index 44b8c83d48..9aa8123985 100644
--- a/toolchain/toolchain-external/toolchain-external.mk
+++ b/toolchain/toolchain-external/toolchain-external.mk
@@ -141,7 +141,7 @@ ifneq ($(TOOLCHAIN_EXTERNAL_PREFIX),)
TOOLCHAIN_EXTERNAL_BIN := $(shell dirname $(shell which $(TOOLCHAIN_EXTERNAL_PREFIX)-gcc))
endif
else
-ifeq ($(BR2_bfin),y)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1)$(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1)$(BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2),y)
TOOLCHAIN_EXTERNAL_BIN := $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/$(TOOLCHAIN_EXTERNAL_PREFIX)/bin
else
TOOLCHAIN_EXTERNAL_BIN := $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/bin
OpenPOWER on IntegriCloud