summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2017-07-05 13:14:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-05 15:19:29 +0200
commit0f9c0bf3d5cdd2f99b66da7ab7e23c7b2bfb8c69 (patch)
treea46d61c940c17cf2b3f5c04bc26f0c7a8b1f9730 /toolchain
parent15bff58f3e627fc328dd2614fabbbae70113794b (diff)
downloadbuildroot-0f9c0bf3d5cdd2f99b66da7ab7e23c7b2bfb8c69.tar.gz
buildroot-0f9c0bf3d5cdd2f99b66da7ab7e23c7b2bfb8c69.zip
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
Since things are no longer installed in $(HOST_DIR)/usr, the callers should also not refer to it. This is a mechanical change with git grep -l '$(HOST_DIR)/usr/bin' | xargs sed -i 's%$(HOST_DIR)/usr/bin%$(HOST_DIR)/bin%g' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/pkg-toolchain-external.mk8
-rw-r--r--toolchain/toolchain-wrapper.mk2
2 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/toolchain-external/pkg-toolchain-external.mk b/toolchain/toolchain-external/pkg-toolchain-external.mk
index 3cba6ff170..33449d37a5 100644
--- a/toolchain/toolchain-external/pkg-toolchain-external.mk
+++ b/toolchain/toolchain-external/pkg-toolchain-external.mk
@@ -54,7 +54,7 @@
# so we're sure the correct configuration is always used and the
# toolchain behaves similar to an internal toolchain.
# This toolchain wrapper and symlinks are installed into
-# $(HOST_DIR)/usr/bin like for the internal toolchains, and the rest
+# $(HOST_DIR)/bin like for the internal toolchains, and the rest
# of Buildroot is handled identical for the 2 toolchain types.
################################################################################
@@ -228,13 +228,13 @@ endif
#
# The following functions creates the symbolic links needed to get the
-# cross-compilation tools visible in $(HOST_DIR)/usr/bin. Some of
+# cross-compilation tools visible in $(HOST_DIR)/bin. Some of
# links are done directly to the corresponding tool in the external
# toolchain installation directory, while some other links are done to
# the toolchain wrapper (preprocessor, C, C++ and Fortran compiler)
#
# We skip gdb symlink when we are building our own gdb to prevent two
-# gdb's in $(HOST_DIR)/usr/bin.
+# gdb's in $(HOST_DIR)/bin.
#
# The LTO support in gcc creates wrappers for ar, ranlib and nm which load
# the lto plugin. These wrappers are called *-gcc-ar, *-gcc-ranlib, and
@@ -243,7 +243,7 @@ endif
# match the *cc-* pattern. Therefore, an additional case is added for *-ar,
# *-ranlib and *-nm.
define TOOLCHAIN_EXTERNAL_INSTALL_WRAPPER
- $(Q)cd $(HOST_DIR)/usr/bin; \
+ $(Q)cd $(HOST_DIR)/bin; \
for i in $(TOOLCHAIN_EXTERNAL_CROSS)*; do \
base=$${i##*/}; \
case "$$base" in \
diff --git a/toolchain/toolchain-wrapper.mk b/toolchain/toolchain-wrapper.mk
index c7b50195d3..7f72a0cade 100644
--- a/toolchain/toolchain-wrapper.mk
+++ b/toolchain/toolchain-wrapper.mk
@@ -44,5 +44,5 @@ endef
define TOOLCHAIN_WRAPPER_INSTALL
$(INSTALL) -D -m 0755 $(@D)/toolchain-wrapper \
- $(HOST_DIR)/usr/bin/toolchain-wrapper
+ $(HOST_DIR)/bin/toolchain-wrapper
endef
OpenPOWER on IntegriCloud