summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>2017-02-07 22:56:44 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-04-05 21:32:13 +0200
commit144caf5c5b0378b6f508c261c01279636db7eb15 (patch)
tree95f3b85730b10b77682f2714f932a1d1c97f1a08 /toolchain/helpers.mk
parenta06edf201b4954e441065b565fe7fd677f8e41ea (diff)
downloadbuildroot-144caf5c5b0378b6f508c261c01279636db7eb15.tar.gz
buildroot-144caf5c5b0378b6f508c261c01279636db7eb15.zip
toolchain helpers: introduce simplify_symlink
The external toolchain logic flattens the directory layout in the staging directory. Regardless of the number of levels present in the extracted toolchain, libraries are always copied to lib/ and usr/lib/, and directory symbolic links are provided to make the original paths available as well. Due to this, the same library may be reachable through a number of paths: one path without any symbolic link, and one or more paths using directory symlinks. Using a direct path in a symlink destination is generally preferred because it is clearer, but it is also more robust against accidental removal of an intermediate directory symlink. Introduce a helper function to simplify a symlink's destination to such a direct path. This function will be used in a subsequent patch. Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 16864854b4..5137b5d102 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -451,3 +451,30 @@ $$( \
printf "$$prefix" ; \
)
endef
+
+# Replace the destination of a symbolic link with a simpler version
+# For example,
+# usr/lib/libfoo.so -> ../../lib32/libfoo.so.1
+# becomes
+# usr/lib/libfoo.so -> ../../lib/libfoo.so.1
+# since 'lib32' is a symlink to 'lib'.
+#
+# Likewise,
+# usr/lib/octeon2/libbar.so -> ../../../lib32/octeon2/libbar.so.1
+# becomes
+# usr/lib/octeon2/libbar.so -> ../../lib/libbar.so.1
+# assuming lib32->lib and lib/octeon2->lib.
+#
+# $1: symlink
+# $2: base path
+define simplify_symlink
+( \
+ FULL_SRC="$$(readlink -f $$(dirname $1))/$$(basename $1)" ; \
+ FULL_DEST="$$(readlink -f $1)" ; \
+ FULL_BASE="$$(readlink -f $2)" ; \
+ REL_SRC="$${FULL_SRC#$${FULL_BASE}/}" ; \
+ REL_DEST="$${FULL_DEST#$${FULL_BASE}/}" ; \
+ DOTS="$(call relpath_prefix,$${REL_SRC})" ; \
+ ln -sf "$${DOTS}$${REL_DEST}" "$${FULL_SRC}" ; \
+)
+endef
OpenPOWER on IntegriCloud