summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorKrzysztof Konopko <kris@youview.com>2017-03-09 09:01:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-09 21:25:24 +0100
commit06cd604ec6d34f25b436ab729543418042a87e1c (patch)
treefd14e0a0093145c9a56a83d9044235518c3e39da /toolchain/helpers.mk
parentece884a7042a1cfeb733c786714866087ad24d73 (diff)
downloadbuildroot-06cd604ec6d34f25b436ab729543418042a87e1c.tar.gz
buildroot-06cd604ec6d34f25b436ab729543418042a87e1c.zip
toolchain/external: use -dumpversion to check gcc version
Currently, `--version` option is used and later matched with a regex to get the actual gcc version. There's a dedicated gcc option to do exactly that: `-dumpversion`. Also `--version` may return a string customised by a vendor that provides the toolchain, which makes the current regex approach error prone. In fact, this situation has been seen with a real customised toolchain. Signed-off-by: Krzysztof Konopko <kris@youview.com> Signed-off-by: Tomasz Szkutkowski <tomasz.szkutkowski@youview.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 6f87230796..6044b7e5f4 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -148,7 +148,7 @@ check_gcc_version = \
if [ -z "$${expected_version}" ]; then \
exit 0 ; \
fi; \
- real_version=`$(1) --version | sed -r -e '1!d; s/^[^)]+\) ([^[:space:]]+).*/\1/;'` ; \
+ real_version=`$(1) -dumpversion` ; \
if [[ ! "$${real_version}" =~ ^$${expected_version}\. ]] ; then \
printf "Incorrect selection of gcc version: expected %s.x, got %s\n" \
"$${expected_version}" "$${real_version}" ; \
OpenPOWER on IntegriCloud