summaryrefslogtreecommitdiffstats
path: root/support
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2016-08-17 23:19:36 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-18 22:27:19 +0200
commite8c3755676111dbd5c45d556da7982993e33e227 (patch)
tree84031a0610cb494a462af0d211b3aeb43feddf22 /support
parentb0f0367d3a31fd86fd44075f44cca0ca654c3cd7 (diff)
downloadbuildroot-e8c3755676111dbd5c45d556da7982993e33e227.tar.gz
buildroot-e8c3755676111dbd5c45d556da7982993e33e227.zip
pkg-cmake.mk: set CMAKE_SYSROOT variable in toolchainfile.cmake
This change enforces the CMAKE_SYSROOT value set in the toolchainfile.cmake. This fix overrides the CMake heuristics used to guess it, and turns off some non-desirable behavior adding "-isystem ..." flags to the compiler command line, misleading the compiler and making the build failed due to some unfound standard headers. Fixes: http://autobuild.buildroot.net/results/f7e/f7e92678e91a6cb15ccf32d4a7d75b39f49d6000/defconfig (and others) Cc: Ben Boeckel <mathstuf@gmail.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support')
-rw-r--r--support/misc/toolchainfile.cmake.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/support/misc/toolchainfile.cmake.in b/support/misc/toolchainfile.cmake.in
index e550b8f5ed..649b52d72a 100644
--- a/support/misc/toolchainfile.cmake.in
+++ b/support/misc/toolchainfile.cmake.in
@@ -19,6 +19,7 @@ set(CMAKE_EXE_LINKER_FLAGS "@@TARGET_LDFLAGS@@ ${CMAKE_EXE_LINKER_FLAGS}" CACHE
set(CMAKE_INSTALL_SO_NO_EXE 0)
set(CMAKE_PROGRAM_PATH "${RELOCATED_HOST_DIR}/usr/bin")
+set(CMAKE_SYSROOT "${RELOCATED_HOST_DIR}/@@STAGING_SUBDIR@@")
set(CMAKE_FIND_ROOT_PATH "${RELOCATED_HOST_DIR}/@@STAGING_SUBDIR@@")
set(CMAKE_FIND_ROOT_PATH_MODE_PROGRAM NEVER)
set(CMAKE_FIND_ROOT_PATH_MODE_PACKAGE ONLY)
OpenPOWER on IntegriCloud