summaryrefslogtreecommitdiffstats
path: root/support
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-01-28 11:41:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-26 23:44:04 +0200
commitc5fa9308ea4e3810a7f7d9d0df75cbf090c414c4 (patch)
treea75c89b705cefccd62d4e52d903364caec8f48bc /support
parentf30a3940c8dc5fc9bbe3a0ace457201808142183 (diff)
downloadbuildroot-c5fa9308ea4e3810a7f7d9d0df75cbf090c414c4.tar.gz
buildroot-c5fa9308ea4e3810a7f7d9d0df75cbf090c414c4.zip
core/br2-external: properly report unexpected errors
Unextected error in the br2-external script are properly caught, but they are not reported properly, and we end up in either of two situations: - the .br2-external.mk file is not generated, in which case make will try to find a rule to generate it (because the 'include' directive tries to generate missing files); - the .br-external.mk file is generated but does not contain the error variable, and thus the build might not get interrupted. We fix that by using a trap on the pseudo ERR signal, to emit the error variable on unexpected errors. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support')
-rwxr-xr-xsupport/scripts/br2-external3
1 files changed, 3 insertions, 0 deletions
diff --git a/support/scripts/br2-external b/support/scripts/br2-external
index 26bcac8aa1..7e816081a1 100755
--- a/support/scripts/br2-external
+++ b/support/scripts/br2-external
@@ -40,6 +40,9 @@ main() {
exec >"${ofile}"
+ # Trap any unexpected error to generate a meaningful error message
+ trap "error 'unexpected error while generating ${ofile}\n'" ERR
+
do_validate ${@//:/ }
do_${ofmt}
OpenPOWER on IntegriCloud