summaryrefslogtreecommitdiffstats
path: root/support
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-09-21 15:31:16 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-10-10 21:30:51 +0200
commitb2c24f584d163a6e5170f4a025aa1094b468527a (patch)
tree0b8a0663ebfd005d5711ccd5915bab4488767a29 /support
parentcf9344c45e85ed274cf783271344f4c03138971d (diff)
downloadbuildroot-b2c24f584d163a6e5170f4a025aa1094b468527a.tar.gz
buildroot-b2c24f584d163a6e5170f4a025aa1094b468527a.zip
package/pkg-generic.mk: increase precision of timestamps
Currently, the timestamps that we keep in build-time.log use a second-level precision. However, as we are going to introduce a new type of graph to draw the time line of a build, this precision is going to be insufficient, as a number of steps are so short that they are not even one second long, and generally the rounding to the second gives a not so great looking graph. Therefore, we add to the timestamps the nanoseconds using the %N date specifier. A milli-second precision would have been sufficient, but %N is all what date(1) provides at the sub-second level. Since this is changing the format of the build-time.log file, this commit adjusts the support/scripts/graph-build-time script accordingly, to account for the floating point numbers that we have as timestamps. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'support')
-rwxr-xr-xsupport/scripts/graph-build-time2
1 files changed, 1 insertions, 1 deletions
diff --git a/support/scripts/graph-build-time b/support/scripts/graph-build-time
index 415d431f23..892e08bf07 100755
--- a/support/scripts/graph-build-time
+++ b/support/scripts/graph-build-time
@@ -260,7 +260,7 @@ def read_data(input_file):
return None
for row in reader:
- time = int(row[0].strip())
+ time = float(row[0].strip())
state = row[1].strip()
step = row[2].strip()
pkg = row[3].strip()
OpenPOWER on IntegriCloud