summaryrefslogtreecommitdiffstats
path: root/support/testing
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2018-11-10 00:16:09 -0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-11-13 20:55:49 +0100
commitad361c69f6003bc1e5df5bf6a6b64fe8d9b54645 (patch)
tree204ed99ab8dff2aeeda3673bf2891650c0c06121 /support/testing
parent6a24761c72e164e776056b891532e8d6a276e37f (diff)
downloadbuildroot-ad361c69f6003bc1e5df5bf6a6b64fe8d9b54645.tar.gz
buildroot-ad361c69f6003bc1e5df5bf6a6b64fe8d9b54645.zip
support/testing: add python-crossbar tests
This test invokes "crossbar version" command, that checks all dependencies found in setup.py files and prints some system related information. Add haveged to the target to generate enough entropy so crossbar -> pynacl -> libsodium don't hang waiting for /dev/random. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> [Ricardo: move test script to a separate file, remove Python 2 variant, add haveged to target to add entropy and avoid hanging] Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'support/testing')
-rw-r--r--support/testing/tests/package/sample_python_crossbar.py3
-rw-r--r--support/testing/tests/package/test_python_crossbar.py14
2 files changed, 17 insertions, 0 deletions
diff --git a/support/testing/tests/package/sample_python_crossbar.py b/support/testing/tests/package/sample_python_crossbar.py
new file mode 100644
index 0000000000..3695fe92c0
--- /dev/null
+++ b/support/testing/tests/package/sample_python_crossbar.py
@@ -0,0 +1,3 @@
+import crossbar
+
+crossbar.run(["version"])
diff --git a/support/testing/tests/package/test_python_crossbar.py b/support/testing/tests/package/test_python_crossbar.py
new file mode 100644
index 0000000000..2d7b739b5c
--- /dev/null
+++ b/support/testing/tests/package/test_python_crossbar.py
@@ -0,0 +1,14 @@
+from tests.package.test_python import TestPythonPackageBase
+
+
+class TestPythonPy3Crossbar(TestPythonPackageBase):
+ __test__ = True
+ # use haveged to generate enough entropy so crossbar -> pynacl -> libsodium don't hang waiting for /dev/random
+ config = TestPythonPackageBase.config + \
+ """
+ BR2_PACKAGE_PYTHON3=y
+ BR2_PACKAGE_PYTHON_CROSSBAR=y
+ BR2_PACKAGE_HAVEGED=y
+ """
+ sample_scripts = ["tests/package/sample_python_crossbar.py"]
+ timeout = 60
OpenPOWER on IntegriCloud