summaryrefslogtreecommitdiffstats
path: root/support/dependencies
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2018-02-27 09:55:40 +0100
committerPeter Korsgaard <peter@korsgaard.com>2018-02-27 17:01:47 +0100
commit7c09cb82b75f30eba7a9daaae5e77a604f6e49c1 (patch)
tree6845dc81858582e1c6672cc55d3c62fdb9e70f17 /support/dependencies
parente0eec7a4f752364b5ca2580979f28435be0a41a2 (diff)
downloadbuildroot-7c09cb82b75f30eba7a9daaae5e77a604f6e49c1.tar.gz
buildroot-7c09cb82b75f30eba7a9daaae5e77a604f6e49c1.zip
dependencies.mk: check for valid host-tar before other host dependencies
host-{cmake,lzip,xz} needs host-tar to extract their source code tarball, so we need to ensure that host-tar gets added to DEPENDENCIES_HOST_PREREQ before these in case they are both needed, otherwise the tools will fail to extract. With the upcoming change to blacklist modern tar versions this situation is likely to trigger more often. The real solution to this issue is the <foo>_EXTRACT_DEPENDENCIES rework, but that series is a bit too intrusive to add this close to 2018.02, so therefore this hack. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'support/dependencies')
-rw-r--r--support/dependencies/dependencies.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index 4f606f849d..3fc235863c 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -12,7 +12,10 @@
define suitable-host-package
$(shell support/dependencies/check-host-$(1).sh $(2))
endef
--include $(sort $(wildcard support/dependencies/check-host-*.mk))
+# host utilities needs host-tar to extract the source code tarballs, so
+# ensure check-host-tar.mk is included before the rest
+include support/dependencies/check-host-tar.mk
+-include $(sort $(filter-out %-tar.mk,$(wildcard support/dependencies/check-host-*.mk)))
ifeq ($(BR2_CCACHE),y)
DEPENDENCIES_HOST_PREREQ += host-ccache
OpenPOWER on IntegriCloud