summaryrefslogtreecommitdiffstats
path: root/support/dependencies
diff options
context:
space:
mode:
authorCarlos Santos <casantos@datacom.ind.br>2017-05-07 01:32:18 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-06-24 21:23:53 +0200
commit77a7a15e4c14d2b39e661dca9b7c94e773b00e93 (patch)
treece9c010c8ca2f674fe2287e132cfa810afdaca97 /support/dependencies
parent82f64203a8f017d50b754323194694374f92add5 (diff)
downloadbuildroot-77a7a15e4c14d2b39e661dca9b7c94e773b00e93.tar.gz
buildroot-77a7a15e4c14d2b39e661dca9b7c94e773b00e93.zip
core: reverse the argument order in check-host-cmake
Pass the minimal version before the program name. In a later change the script will become able to test a list of candidates. Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support/dependencies')
-rw-r--r--support/dependencies/check-host-cmake.mk2
-rwxr-xr-xsupport/dependencies/check-host-cmake.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/support/dependencies/check-host-cmake.mk b/support/dependencies/check-host-cmake.mk
index 8002278a3b..914327fe1a 100644
--- a/support/dependencies/check-host-cmake.mk
+++ b/support/dependencies/check-host-cmake.mk
@@ -12,7 +12,7 @@ BR2_CMAKE_VERSION_MIN = 3.1
BR2_CMAKE ?= cmake
ifeq ($(call suitable-host-package,cmake,\
- $(BR2_CMAKE) $(BR2_CMAKE_VERSION_MIN)),)
+ $(BR2_CMAKE_VERSION_MIN) $(BR2_CMAKE)),)
BR2_CMAKE = $(HOST_DIR)/usr/bin/cmake
BR2_CMAKE_HOST_DEPENDENCY = host-cmake
endif
diff --git a/support/dependencies/check-host-cmake.sh b/support/dependencies/check-host-cmake.sh
index 9b63b0648d..73bd4edc99 100755
--- a/support/dependencies/check-host-cmake.sh
+++ b/support/dependencies/check-host-cmake.sh
@@ -1,7 +1,7 @@
#!/bin/sh
-candidate="${1}"
-version_min="${2}"
+version_min="${1}"
+candidate="${2}"
major_min="${version_min%.*}"
minor_min="${version_min#*.}"
OpenPOWER on IntegriCloud