summaryrefslogtreecommitdiffstats
path: root/support/dependencies
diff options
context:
space:
mode:
authorJulius Kriukas <julius@kriukas.lt>2018-02-23 01:00:55 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-03-02 22:44:34 +0100
commit41569717c34a2334c8682985d8457447b9b5093a (patch)
treecfba58d723746e32b261db432ba9b08bf69c2772 /support/dependencies
parent1fa7233fdf8920e7199b380b732c61fa9bdf2dbd (diff)
downloadbuildroot-41569717c34a2334c8682985d8457447b9b5093a.tar.gz
buildroot-41569717c34a2334c8682985d8457447b9b5093a.zip
systemd: switch to C.UTF-8 locale when building
When BR2_REPRODUCIBLE is enabled or host uses non UTF-8 capable locale building systemd fails with an error: [1/1080] Generating systemd.bg.catalog with a meson_exe.py custom command. FAILED: catalog/systemd.bg.catalog /buildroot/output/host/bin/python3 /buildroot/output/host/bin/meson --internal exe /buildroot/output/build/systemd-236/build/meson-private/meson_exe_sed_232a0623cc7ce2cd67ec72ed784b76307102ed76.dat Warning: You are using 'ANSI_X3.4-1968' which is not a Unicode-compatible locale. You might see errors if you use UTF-8 strings as filenames, as strings, or as file contents. Please switch to a UTF-8 locale for your platform. ... UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 1079: ordinal not in range(128) package/pkg-generic.mk:247: recipe for target '/buildroot/output/build/systemd-236/.stamp_built' failed make: *** [/buildroot/output/build/systemd-236/.stamp_built] Error 1 This patch changes default host system locale from C to C.UTF-8 when building systemd package to fix this issue. It also introduces BR2_NEEDS_HOST_C_UTF8_LOCALE flag that checks if this locale is available on the host system. If locale is not available error message is show and build process is stopped. Signed-off-by: Julius Kriukas <julius@kriukas.lt> [Thomas: use C.UTF-8 instead of en_US.UTF-8.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'support/dependencies')
-rwxr-xr-xsupport/dependencies/dependencies.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/support/dependencies/dependencies.sh b/support/dependencies/dependencies.sh
index 1804e85508..17dbe08fa4 100755
--- a/support/dependencies/dependencies.sh
+++ b/support/dependencies/dependencies.sh
@@ -207,6 +207,19 @@ if grep ^BR2_NEEDS_HOST_UTF8_LOCALE=y $BR2_CONFIG > /dev/null; then
fi
fi
+if grep -q ^BR2_NEEDS_HOST_C_UTF8_LOCALE=y $BR2_CONFIG; then
+ if ! which locale > /dev/null ; then
+ echo
+ echo "You need locale support on your build machine"
+ exit 1 ;
+ fi
+ if ! LC_ALL=C.UTF-8 locale -c charmap | grep -q '^UTF-8$'; then
+ echo
+ echo "You need C.UTF-8 locale suppport on the host system"
+ exit 1 ;
+ fi
+fi
+
if grep -q ^BR2_NEEDS_HOST_JAVA=y $BR2_CONFIG ; then
check_prog_host "java"
JAVA_GCJ=$(java -version 2>&1 | grep gcj)
OpenPOWER on IntegriCloud