summaryrefslogtreecommitdiffstats
path: root/support/dependencies
diff options
context:
space:
mode:
authorAlfredo Alvarez Fernandez <alfredo.alvarez_fernandez@nokia.com>2017-04-28 11:35:20 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-10-22 15:42:26 +0200
commit36d398ac30f35ca9d4405a9dee2b33560ec3595d (patch)
treec88423952c355fef24200943bd0a9a638cd19653 /support/dependencies
parent90b9b457ecd5e6ebea9d48f36c030b95ca67059b (diff)
downloadbuildroot-36d398ac30f35ca9d4405a9dee2b33560ec3595d.tar.gz
buildroot-36d398ac30f35ca9d4405a9dee2b33560ec3595d.zip
dependencies: always use HOSTCC_NOCACHE for DEPENDENCIES_HOST_PREREQ
Currently, HOSTCC and HOSTCXX are set to their _NOCACHE variants in the 'dependencies' target. This is needed because at that time, ccache is not built yet - host-ccache is one of the dependencies. However, because this override is only specified for the 'dependencies' target (and thereby gets inherited by its dependencies), the override is only applied when the package is reached through the 'dependencies' target. This is not the case when one of DEPENDENCIES_HOST_PREREQ is built directly from the command line, e.g. when doing 'make host-ccache'. So in that case, ccache will be built with ccache... which fails of course. To fix this, directly apply the override to the DEPENCIES_HOST_PREREQ targets. Note that this only fixes the issue for 'make host-ccache', NOT for e.g. 'make host-ccache-configure'. Signed-off-by: Alfredo Alvarez Fernandez <alfredo.alvarez_fernandez@nokia.com> [Arnout: improve commit message] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'support/dependencies')
-rw-r--r--support/dependencies/dependencies.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index d4b0409cda..ef2ae9b7e1 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -23,8 +23,8 @@ core-dependencies:
DL_TOOLS="$(sort $(DL_TOOLS_DEPENDENCIES))" \
$(TOPDIR)/support/dependencies/dependencies.sh
-dependencies: HOSTCC=$(HOSTCC_NOCCACHE)
-dependencies: HOSTCXX=$(HOSTCXX_NOCCACHE)
+core-dependencies $(DEPENDENCIES_HOST_PREREQ): HOSTCC=$(HOSTCC_NOCCACHE)
+core-dependencies $(DEPENDENCIES_HOST_PREREQ): HOSTCXX=$(HOSTCXX_NOCCACHE)
dependencies: core-dependencies $(DEPENDENCIES_HOST_PREREQ)
################################################################################
OpenPOWER on IntegriCloud