summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2017-03-24 00:51:38 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-25 15:17:44 +0100
commitf48f1a89a0c598ebefd2643af3ad6aff981e291c (patch)
treee658aba40092c439405d40647a26a852e78a7619 /package
parent197e473ce0acbefd5f05762febf817361123a268 (diff)
downloadbuildroot-f48f1a89a0c598ebefd2643af3ad6aff981e291c.tar.gz
buildroot-f48f1a89a0c598ebefd2643af3ad6aff981e291c.zip
qt: add enable for truetype font installation
Currently, qt.mk installs DejaVu/Vera TrueType fonts when Qt is configured for freetype support. However, some users may prefer to limit the installed fonts to only Qt's prerendered fonts (micro, fixed, helvetica, etc.). Or, there may be a preference to use seperately installed TrueType fonts. This commit adds a switch to explicitly control the installation of the TrueType fonts, similar to the existing prerendered font enables. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Reviewed-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/qt/Config.in8
-rw-r--r--package/qt/qt.mk2
2 files changed, 9 insertions, 1 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index fa5235d6f4..a7617592a6 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -185,6 +185,14 @@ endmenu
menu "Fonts"
+config BR2_PACKAGE_QT_FONT_TRUETYPE
+ bool "dejavu/vera"
+ depends on BR2_PACKAGE_QT_QTFREETYPE || BR2_PACKAGE_QT_SYSTEMFREETYPE
+ default y
+
+comment "dejavu/vera fonts need freetype support"
+ depends on !BR2_PACKAGE_QT_QTFREETYPE && !BR2_PACKAGE_QT_SYSTEMFREETYPE
+
config BR2_PACKAGE_QT_FONT_MICRO
bool "micro"
default y
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index e82bdfe801..1faab74dbd 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -689,7 +689,7 @@ QT_LICENSE_FILES += src/3rdparty/fonts/COPYRIGHT.Unifont
endif
endif # QT_FONTS
-ifeq ($(BR2_PACKAGE_QT_QTFREETYPE)$(BR2_PACKAGE_QT_SYSTEMFREETYPE),y)
+ifeq ($(BR2_PACKAGE_QT_FONT_TRUETYPE),y)
define QT_INSTALL_TARGET_FONTS_TTF
mkdir -p $(TARGET_DIR)/usr/lib/fonts
cp -dpf $(STAGING_DIR)/usr/lib/fonts/*.ttf $(TARGET_DIR)/usr/lib/fonts
OpenPOWER on IntegriCloud