summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2018-10-12 10:11:49 -0400
committerPeter Korsgaard <peter@korsgaard.com>2018-10-14 22:47:31 +0200
commitec5378038f80f444ce7f5106283c7cccb8faae16 (patch)
tree5bf5f3b8f708b2cd5b78eff1e6e0df51123da94a /package
parentd6fcf044a747284df4eddaf106082ebb571976b3 (diff)
downloadbuildroot-ec5378038f80f444ce7f5106283c7cccb8faae16.tar.gz
buildroot-ec5378038f80f444ce7f5106283c7cccb8faae16.zip
erlang: always use Buildroot's zlib
While Erlang includes a version of zlib, it's intended for Windows and there's an expectation that non-Windows platforms provide it. It's also not as regularly updated as the one in Buildroot. This change makes Erlang always use a Buildroot-provided zlib. Fixes this compile error: CC /home/buildroot/autobuild/run/instance-0/output/build/erlang-21.0/erts/emulator/zlib/obj/x86_64-buildroot-linux-musl/opt/adler32.o In file included from zlib/adler32.c:11:0: zlib/zutil.h:172:39: error: "_LFS64_LARGEFILE" is not defined [-Werror=undef] (!defined(_LARGEFILE64_SOURCE) || _LFS64_LARGEFILE-0 == 0) ^~~~~~~~~~~~~~~~ See http://autobuild.buildroot.net/results/fc633f80c7c36a90e641487f5a888fbb767c2a54/. Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package')
-rw-r--r--package/erlang/Config.in1
-rw-r--r--package/erlang/erlang.mk3
2 files changed, 2 insertions, 2 deletions
diff --git a/package/erlang/Config.in b/package/erlang/Config.in
index 75ba17086a..ab87eab6ff 100644
--- a/package/erlang/Config.in
+++ b/package/erlang/Config.in
@@ -23,6 +23,7 @@ config BR2_PACKAGE_ERLANG
depends on !BR2_STATIC_LIBS
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
+ select BR2_PACKAGE_ZLIB
help
Erlang is a programming language used to build massively
scalable soft real-time systems with requirements on high
diff --git a/package/erlang/erlang.mk b/package/erlang/erlang.mk
index 2ac903ffea..ca0aa0b770 100644
--- a/package/erlang/erlang.mk
+++ b/package/erlang/erlang.mk
@@ -64,10 +64,9 @@ else
ERLANG_CONF_OPTS += --without-odbc
endif
-ifeq ($(BR2_PACKAGE_ZLIB),y)
+# Always use Buildroot's zlib
ERLANG_CONF_OPTS += --enable-shared-zlib
ERLANG_DEPENDENCIES += zlib
-endif
# Remove source, example, gs and wx files from staging and target.
ERLANG_REMOVE_PACKAGES = gs wx
OpenPOWER on IntegriCloud