summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-11-21 17:36:16 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-18 22:57:16 +0100
commitc785b1b2c4dc51f24f72a82b1d36a8180c220d90 (patch)
tree28b1c4888ac5d2d72276501688d7b5eda97072b2 /package
parent09f1a3b9ebd380b42fb63f83dd43d9c9bf7b3370 (diff)
downloadbuildroot-c785b1b2c4dc51f24f72a82b1d36a8180c220d90.tar.gz
buildroot-c785b1b2c4dc51f24f72a82b1d36a8180c220d90.zip
toolchain-external: CodeSourcery NIOSII: support only one version
See the conclusion about external toolchains during the Buildroot meeting [1]: "In the future, we stick to a single external toolchain version. The Kconfig symbol should not encode the version (avoid legacy handling)" [1] http://elinux.org/index.php?title=Buildroot:DeveloperDaysELCE2015#Report Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/aiccu/Config.in6
-rw-r--r--package/boost/Config.in3
-rw-r--r--package/connman/Config.in2
-rw-r--r--package/crda/Config.in6
-rw-r--r--package/cryptsetup/Config.in6
-rw-r--r--package/dmraid/Config.in6
-rw-r--r--package/flann/Config.in2
-rw-r--r--package/janus-gateway/Config.in6
-rw-r--r--package/libcap-ng/Config.in2
-rw-r--r--package/libmicrohttpd/Config.in6
-rw-r--r--package/libssh2/Config.in3
-rw-r--r--package/libupnpp/Config.in6
-rw-r--r--package/lxc/Config.in6
-rw-r--r--package/mesa3d/Config.in6
-rw-r--r--package/mosquitto/Config.in6
-rw-r--r--package/ofono/Config.in4
-rw-r--r--package/php-ssh2/Config.in3
-rw-r--r--package/pixman/pixman.mk2
-rw-r--r--package/upmpdcli/Config.in6
-rw-r--r--package/util-linux/Config.in2
20 files changed, 31 insertions, 58 deletions
diff --git a/package/aiccu/Config.in b/package/aiccu/Config.in
index 4a0d20d71d..2bfd649d26 100644
--- a/package/aiccu/Config.in
+++ b/package/aiccu/Config.in
@@ -4,8 +4,7 @@ config BR2_PACKAGE_AICCU
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_USE_MMU # fork()
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
select BR2_PACKAGE_GNUTLS
help
SixXS Automatic IPv6 Connectivity Client Utility
@@ -24,5 +23,4 @@ config BR2_PACKAGE_AICCU
comment "aiccu needs a toolchain w/ wchar, threads"
depends on BR2_USE_MMU
depends on !(BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS)
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/boost/Config.in b/package/boost/Config.in
index 83f6871e89..03935e8c82 100644
--- a/package/boost/Config.in
+++ b/package/boost/Config.in
@@ -3,8 +3,7 @@ comment "boost needs a toolchain w/ C++, threads, wchar"
config BR2_PACKAGE_BOOST_ARCH_SUPPORTS
bool
- default y if !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 && \
- !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
+ default y if !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
config BR2_PACKAGE_BOOST
bool "boost"
diff --git a/package/connman/Config.in b/package/connman/Config.in
index 5ca38bf11a..655db865c5 100644
--- a/package/connman/Config.in
+++ b/package/connman/Config.in
@@ -53,7 +53,7 @@ config BR2_PACKAGE_CONNMAN_NEARD
config BR2_PACKAGE_CONNMAN_OFONO
bool "enable ofono support"
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # libcap-ng
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII # libcap-ng
select BR2_PACKAGE_OFONO
config BR2_PACKAGE_CONNMAN_DEBUG
diff --git a/package/crda/Config.in b/package/crda/Config.in
index 5318fc1de6..4eb1643606 100644
--- a/package/crda/Config.in
+++ b/package/crda/Config.in
@@ -7,8 +7,7 @@ config BR2_PACKAGE_CRDA
# regdb is a runtime dependency
select BR2_PACKAGE_WIRELESS_REGDB
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
Central Regulatory Domain Agent.
@@ -21,5 +20,4 @@ config BR2_PACKAGE_CRDA
comment "crda needs a toolchain w/ threads, dynamic library"
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/cryptsetup/Config.in b/package/cryptsetup/Config.in
index d7ccd379e6..321b97da1c 100644
--- a/package/cryptsetup/Config.in
+++ b/package/cryptsetup/Config.in
@@ -10,8 +10,7 @@ config BR2_PACKAGE_CRYPTSETUP
depends on !BR2_STATIC_LIBS # lvm2
depends on BR2_USE_WCHAR # util-linux
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
This tool helps manipulate dm-crypt and luks partitions for
on-disk encryption.
@@ -21,5 +20,4 @@ config BR2_PACKAGE_CRYPTSETUP
comment "cryptsetup needs a toolchain w/ wchar, threads, dynamic library"
depends on BR2_USE_MMU
depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/dmraid/Config.in b/package/dmraid/Config.in
index ec50670d56..d278a116b2 100644
--- a/package/dmraid/Config.in
+++ b/package/dmraid/Config.in
@@ -4,8 +4,7 @@ config BR2_PACKAGE_DMRAID
depends on BR2_USE_MMU # lvm2
depends on !BR2_STATIC_LIBS # lvm2
# dmraid triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
select BR2_PACKAGE_LVM2
help
dmraid discovers, activates, deactivates and displays properties
@@ -17,6 +16,5 @@ config BR2_PACKAGE_DMRAID
comment "dmraid needs a toolchain w/ threads, dynamic library"
depends on BR2_USE_MMU
# dmraid triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/flann/Config.in b/package/flann/Config.in
index 1222310bfd..3725fc784f 100644
--- a/package/flann/Config.in
+++ b/package/flann/Config.in
@@ -2,8 +2,6 @@ config BR2_PACKAGE_FLANN
bool "flann"
depends on BR2_INSTALL_LIBSTDCPP
depends on !BR2_STATIC_LIBS
- # triggers an assert in the linker of this toolchain
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
help
FLANN is a library for performing fast approximate nearest
neighbor searches in high dimensional spaces. It contains a
diff --git a/package/janus-gateway/Config.in b/package/janus-gateway/Config.in
index cafad94dc3..1c00d323e7 100644
--- a/package/janus-gateway/Config.in
+++ b/package/janus-gateway/Config.in
@@ -11,8 +11,7 @@ config BR2_PACKAGE_JANUS_GATEWAY
depends on BR2_USE_WCHAR # libnice -> libglib2
depends on BR2_USE_MMU # libnice
depends on !BR2_STATIC_LIBS # dlopen
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305 # libmicrohttpd
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # libmicrohttpd
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII # libmicrohttpd
help
Janus is an open source, general purpose, WebRTC gateway
designed and developed by Meetecho.
@@ -22,5 +21,4 @@ config BR2_PACKAGE_JANUS_GATEWAY
comment "janus-gateway needs a toolchain w/ dynamic library, threads, wchar"
depends on BR2_USE_MMU
depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/libcap-ng/Config.in b/package/libcap-ng/Config.in
index a52d230e60..4939e262ac 100644
--- a/package/libcap-ng/Config.in
+++ b/package/libcap-ng/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_LIBCAP_NG
bool "libcap-ng"
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # triggers compiler bug
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII # triggers compiler bug
help
The libcap-ng library is intended to make programming with
posix capabilities much easier than the traditional libcap
diff --git a/package/libmicrohttpd/Config.in b/package/libmicrohttpd/Config.in
index d9e6493776..68191ea7cf 100644
--- a/package/libmicrohttpd/Config.in
+++ b/package/libmicrohttpd/Config.in
@@ -2,8 +2,7 @@ config BR2_PACKAGE_LIBMICROHTTPD
bool "libmicrohttpd"
depends on BR2_TOOLCHAIN_HAS_THREADS
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
GNU libmicrohttpd is a small C library that makes it easy to
run an HTTP server as part of another application.
@@ -27,5 +26,4 @@ endif
comment "libmicrohttpd needs a toolchain w/ threads"
depends on !BR2_TOOLCHAIN_HAS_THREADS
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/libssh2/Config.in b/package/libssh2/Config.in
index 341624069a..ea4bb3b0b8 100644
--- a/package/libssh2/Config.in
+++ b/package/libssh2/Config.in
@@ -2,8 +2,7 @@ config BR2_PACKAGE_LIBSSH2
bool "libssh2"
select BR2_PACKAGE_LIBGCRYPT if !BR2_PACKAGE_OPENSSL
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
libssh2 is a client-side C library implementing the SSH2
protocol as defined by Internet Drafts: SECSH-TRANS(22),
diff --git a/package/libupnpp/Config.in b/package/libupnpp/Config.in
index 8af0cda698..1dfd3c7920 100644
--- a/package/libupnpp/Config.in
+++ b/package/libupnpp/Config.in
@@ -7,8 +7,7 @@ config BR2_PACKAGE_LIBUPNPP
depends on BR2_TOOLCHAIN_HAS_THREADS # libupnp
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
The libupnpp C++ library wraps libupnp for easier use by upmpdcli and
upplay.
@@ -16,6 +15,5 @@ config BR2_PACKAGE_LIBUPNPP
http://www.lesbonscomptes.com/upmpdcli/
comment "libupnpp needs a toolchain w/ C++, threads, gcc >= 4.5"
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
diff --git a/package/lxc/Config.in b/package/lxc/Config.in
index ffd9b4a061..a5df3e32eb 100644
--- a/package/lxc/Config.in
+++ b/package/lxc/Config.in
@@ -6,8 +6,7 @@ config BR2_PACKAGE_LXC
# build system forcefully builds a shared library
depends on !BR2_STATIC_LIBS
# the toolchain doesn't support setns syscall
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # libcap
help
Linux Containers (LXC), provides the ability to group and isolate
@@ -18,8 +17,7 @@ config BR2_PACKAGE_LXC
comment "lxc needs a toolchain w/ threads, headers >= 3.0, dynamic library"
depends on BR2_USE_MMU
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
depends on !BR2_TOOLCHAIN_HAS_THREADS \
|| !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 \
|| BR2_STATIC_LIBS
diff --git a/package/mesa3d/Config.in b/package/mesa3d/Config.in
index fdeb59977c..8dd208f40a 100644
--- a/package/mesa3d/Config.in
+++ b/package/mesa3d/Config.in
@@ -13,8 +13,7 @@ menuconfig BR2_PACKAGE_MESA3D
depends on !BR2_STATIC_LIBS
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
# Triggers the _gp link issue in nios2
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
Mesa 3D, an open-source implementation of the OpenGL specification.
@@ -153,7 +152,6 @@ config BR2_PACKAGE_PROVIDES_LIBGLES
endif # BR2_PACKAGE_MESA3D
comment "mesa3d needs a toolchain w/ C++, NPTL, dynamic library"
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS_NPTL || \
BR2_STATIC_LIBS
diff --git a/package/mosquitto/Config.in b/package/mosquitto/Config.in
index 4053c62259..ab598d07b6 100644
--- a/package/mosquitto/Config.in
+++ b/package/mosquitto/Config.in
@@ -3,8 +3,7 @@ config BR2_PACKAGE_MOSQUITTO
depends on BR2_USE_MMU # fork()
depends on !BR2_STATIC_LIBS # builds .so
# Triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
Mosquitto is an open source message broker that implements
the MQ Telemetry Transport protocol versions 3.1 and
@@ -19,5 +18,4 @@ config BR2_PACKAGE_MOSQUITTO
comment "mosquitto needs a toolchain w/ dynamic library"
depends on BR2_USE_MMU
depends on BR2_STATIC_LIBS
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/ofono/Config.in b/package/ofono/Config.in
index f709b04180..f8365d8274 100644
--- a/package/ofono/Config.in
+++ b/package/ofono/Config.in
@@ -3,7 +3,7 @@ config BR2_PACKAGE_OFONO
depends on BR2_USE_WCHAR # gettext, libglib2
depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
depends on BR2_USE_MMU # dbus, libglib2
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # libcap-ng
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII # libcap-ng
depends on !BR2_STATIC_LIBS # dlopen()
select BR2_PACKAGE_LIBCAP_NG
select BR2_PACKAGE_DBUS
@@ -19,4 +19,4 @@ config BR2_PACKAGE_OFONO
comment "ofono needs a toolchain w/ dynamic library, wchar, threads"
depends on BR2_USE_MMU
depends on BR2_STATIC_LIBS || !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
diff --git a/package/php-ssh2/Config.in b/package/php-ssh2/Config.in
index bc31e1ddbd..9b8a3f82ab 100644
--- a/package/php-ssh2/Config.in
+++ b/package/php-ssh2/Config.in
@@ -3,8 +3,7 @@ config BR2_PACKAGE_PHP_SSH2
depends on BR2_PACKAGE_PHP
select BR2_PACKAGE_LIBSSH2
# Triggers the _gp link issue (libssh2)
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
PHP bindings for the libssh2 library.
diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
index 8845315a2f..e1b7c2dc88 100644
--- a/package/pixman/pixman.mk
+++ b/package/pixman/pixman.mk
@@ -28,7 +28,7 @@ endif
# toolchain gets confused about TLS access through GOT (PIC), so disable TLS
# movhi r4, %got_hiadj(%tls_ldo(fast_path_cache))
# {standard input}:172: Error: bad expression
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405),y)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII),y)
PIXMAN_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
endif
diff --git a/package/upmpdcli/Config.in b/package/upmpdcli/Config.in
index 848c6af849..1502095311 100644
--- a/package/upmpdcli/Config.in
+++ b/package/upmpdcli/Config.in
@@ -6,8 +6,7 @@ config BR2_PACKAGE_UPMPDCLI
depends on BR2_TOOLCHAIN_HAS_THREADS # libupnpp -> libupnp
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_6
# libupnpp triggers the _gp link issue
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
help
upmpdcli is a UPnP Media Renderer front-end for MPD, the Music
Player Daemon. It supports UPnP gapless track transitions and
@@ -16,6 +15,5 @@ config BR2_PACKAGE_UPMPDCLI
http://www.lesbonscomptes.com/upmpdcli/
comment "upmpdcli needs a toolchain w/ C++, threads, gcc >= 4.6"
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_6
diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
index c3ea1907c4..214b975630 100644
--- a/package/util-linux/Config.in
+++ b/package/util-linux/Config.in
@@ -211,7 +211,7 @@ config BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS
config BR2_PACKAGE_UTIL_LINUX_SETPRIV
bool "setpriv"
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # libcap-ng
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII # libcap-ng
select BR2_PACKAGE_LIBCAP_NG
help
Run a program with different Linux privilege settings
OpenPOWER on IntegriCloud