summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2014-10-05 11:40:07 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-05 14:06:59 +0200
commitc5fb6e17235a1ea47af7e85e640fb34a886aeb95 (patch)
treecfa31294052c8835532607e1debbc259bdc76e7d /package
parent8e07296cb9947b18cf24ec980f313d1606485da0 (diff)
downloadbuildroot-c5fb6e17235a1ea47af7e85e640fb34a886aeb95.tar.gz
buildroot-c5fb6e17235a1ea47af7e85e640fb34a886aeb95.zip
package/libplist: fix python support
This patch: - fixes the python3 support detection in the libplist CMake code; - correctly sets the dependencies and configure options in libplist.mk. Fixes: http://autobuild.buildroot.net/results/efb/efba806b9a40a5e9c6bca7e591747ca2102fa1d5/ Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/libplist/libplist-0003-cmake-swig-support-python2-and-python3-when-defining.patch27
-rw-r--r--package/libplist/libplist.mk13
2 files changed, 40 insertions, 0 deletions
diff --git a/package/libplist/libplist-0003-cmake-swig-support-python2-and-python3-when-defining.patch b/package/libplist/libplist-0003-cmake-swig-support-python2-and-python3-when-defining.patch
new file mode 100644
index 0000000000..a5218e8180
--- /dev/null
+++ b/package/libplist/libplist-0003-cmake-swig-support-python2-and-python3-when-defining.patch
@@ -0,0 +1,27 @@
+From 114d242a3b6b749b404cda80304e621556325d34 Mon Sep 17 00:00:00 2001
+From: Samuel Martin <s.martin49@gmail.com>
+Date: Sun, 5 Oct 2014 10:13:06 +0200
+Subject: [PATCH] cmake: swig: support python2 and python3 when defining
+ DISTUTILS_PYTHON_ILIBRARY_PATH
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+---
+ swig/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/swig/CMakeLists.txt b/swig/CMakeLists.txt
+index 379cb95..ae6f0e7 100644
+--- a/swig/CMakeLists.txt
++++ b/swig/CMakeLists.txt
+@@ -9,7 +9,7 @@ SWIG_ADD_MODULE( plist python plist.i )
+ SWIG_LINK_LIBRARIES( plist plist plist++ ${PYTHON_LIBRARIES} )
+
+ EXEC_PROGRAM("${PYTHON_EXECUTABLE}"
+- ARGS "-c 'try:\n import distutils.sysconfig; print distutils.sysconfig.get_python_lib(plat_specific=1)\nexcept: pass\n'"
++ ARGS "-c 'from __future__ import print_function\ntry:\n import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(plat_specific=1))\nexcept: pass\n'"
+ OUTPUT_VARIABLE DISTUTILS_PYTHON_ILIBRARY_PATH
+ )
+
+--
+2.1.2
+
diff --git a/package/libplist/libplist.mk b/package/libplist/libplist.mk
index 87f09c6563..1e44ffff12 100644
--- a/package/libplist/libplist.mk
+++ b/package/libplist/libplist.mk
@@ -12,4 +12,17 @@ LIBPLIST_MAKE = $(MAKE1)
LIBPLIST_LICENSE = LGPLv2.1+
LIBPLIST_LICENSE_FILES = COPYING
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
+LIBPLIST_DEPENDENCIES += \
+ python$(if $(BR2_PACKAGE_PYTHON3),3) \
+ host-swig
+LIBPLIST_CONF_OPTS += \
+ -DENABLE_PYTHON=ON \
+ -DSWIG_EXECUTABLE=$(SWIG)
+else
+LIBPLIST_CONF_OPTS += \
+ -DENABLE_PYTHON=OFF \
+ -DSWIG_EXECUTABLE=SWIG_EXECUTABLE-NOTFOUND
+endif
+
$(eval $(cmake-package))
OpenPOWER on IntegriCloud